Help - Uninstallation Gone Wrong

Hello, I am currently having conflicts unintalling Comodo Firewall Pro 2.4 from my computer. I’ve tried to go through the whole forums, and seemingly none of the problems mentioned seem to be like mine. I’ve realized that Comodo is working on this issue, but I hope someone can shed some light on my problem.

Ok, basically what happens is that when I uninstall CFP, it tells me to reboot my system. I reboot. Upon logging in is where the issue surfaces; I get my wallpaper screen, and that’s it. I am forced to open up Task Manager, end the explorer.exe process, and restart it in order to get my screen. Now, after 2-5 minutes, my major programs finally start, but dont show in my taskbar. Also, my internet connection is permanently lost. I’ve tried reconnecting it before, but to no avail. It seems that after uninstalling CFP, it has crippled my system, with no internet connection. So I go back to my restore point.

I’ve tried many ways to uninstall CFP, because some months ago, about 2 updates earlier, I had a similar problem uninstalling, however it was easily solved by deleting the registry entries. This time, however, isn’t solved by deleting the entries.

These are the attempts I’ve made uninstalling CFP so far:
Add/Remove Programs → Uninstall. Reboot. Failure
Remove cmdagent.exe from Service → Add/Remove Programs → Uninstall. Delete all Registry Entries. Failure.
Safe Mode → Add/Remove Programs → Uninstall. Reboot. Failure.

Each attempt has crippled my system the same way, each recovering by using the System Restore Points. I am hoping that someone can guide me through the installation of CFP 2.4 so my system can be reusable as if I hadn’t uninstalled it. Thank you.

Hi zteel, welcome to the forums.

Perhaps this topic might help. Failing that I recommend that you go to Comodo Support, register on their system & raise a ticket on this issue.

Thank you for the welcome kail, and thank you for your quick response.

I have viewed that topic before, and did as the instructions told; downloaded, extracted, ran to no success either. I have attempted again, and had to restore like last time.

I am worrying about having to do a reinstall of Windows XP SP2. Hopefully, it does not have to end up like that, and Comodo Support can resolve my problems.

I am wondering though; if I run a older executable version of CF, and when it tells me that CFP is installed, and asks me if I should repair or uninstall it first, would that help if it uninstalls, and I intercept the installation of the other? And also, are these problems that I’m experiencing most likely due to the faulty of the program, or perhaps my OS seeing that this problem may not have surfaced publicly before?

Thank you for your quick response once again.

-// EDIT

Okay, at this current moment, it seems that I have successfully removed Comodo Firewall Pro 2.4 from my computer from experimenting. The process I did to get there were pretty much not different, but I think my system is weird that way. (:AGY) I’d say this topic is resolved after some fiddling. I guess it wasn’t important enough to post this? Sorry. But I’ll leave the steps I took just in case a similar problem occurs with someone else. (:WIN)

What I did:
Execute 2.3 CF executable → permit it to uninstall current version before continuing → required to restart.
Restart → system is crippled. After everything seems loaded, rerun 2.3 CF executable → let it install.
Installation complete → reboot required.
Restart → system seems fine now operating on CF 2.3, until I find out that my internet connection is still in shatters, AND Windows Security Center cannot open up the ICS, (Internet(?) C? Service).
I decide to restore my system back to the very restore point made at least 7 points before ever attempting to uninstall CFP.
Whaddya’ know, everything is back to normal, except the fact that I now have CF 2.3, and not CFP 2.4! I don’t know what the hell happened, but the restore point did not bring back the 2.4 version. Also, Add/Remove list did not have CF 2.3 listed, so I had ‘no’ FW installed.
I manually remove all traces of Comodo in the Registry → Shutdown Comodo → remove cmdagent.exe from services → reboot into Safe Mode
Safe Mode → run through Registry; none detected. → Rebuilt the Repository folder to refresh memory of Windows Security Center → reboot
Restart → Security Center detects no firewall installed and turned on. Go through some checks, and sees like CF/CFP is completely removed from my computer!

In another perspective, it could be that CFP update/installation comes with a fault with it’s uninstallation than 2.3. I don’t know if that’s the case, but it’s a possibility, and just a heads up to let you guys know.

I will not be installing Comodo Firewall again. However, I will leave with a happy note. I was very satisfied how CF notified the user of which application was trying to access the internet, thus leaving me with more power on how to control how my system runs. It was nice indeed. Interface was also good. Only backdraw I could think of this product => it can’t properly uninstall itself properly. Keep up the great Firewall guys.