help Setting up a VPN killswitch in Windows 10

I am having an issue trying to make a killswitch for my vpn connection using Comodo firewall. I know there has been probably a hundred posts about how to do this but I cant seam to get any of them to work. My goal is to make a global killswitch that if the VPN goes down, The whole guest OS wont have any internet traffic (not an application-based one).

so I have Windows 10 1909 set up in a guest OS (virtual machine using virtualbox). In virtualbox for networking I have “NAT” selected using my Intel PRO/1000 MT Desktop adapter.

In my guest OS, I have OpenVPN and Comodo Firewall installed. The VPN connects with no issues.

So my Issue is that When I apply these rules in Comodo Firewall Global Rules:

“Allow IP in from MAC any to in “vpn zone” where protocol is any”

“Allow IP out from in “vpn zone” to MAC any where protocol is any”

“Block IP in/out from MAC any to MAC any where protocol is any”

I have “vpn zone” declared as my TAP-Windows Adapter’s Physical Address (MAC address)

it blocks out my vpn and home internet connection. Is there more Rules I need to apply to get this to work.

You may need to set the network type from NAT to bridge mode.

I have tryed that also and I am getting the same result no internet in VPN and Home. I have tryed removing the ALLOW Rules and tested out Blocking “vpn zone” and it did block it. When I tryed just blocking out my Home network it blocked it out and my VPN wouldnt connect eather. I’m guessing the Block rule is blocking something out that is needed for the first two rules but not exactly sure.

Re-create the original global rules and then enable logging on the block rule, then check the firewall logs to see what is getting blocked. I’m guessing DNS and DHCP is being blocked which is needed.

Alright I added the ALLOW rules back in and put the “Log as firewall event if this rule is fired” for the block rule. I looked in the Logs and noticed that DNS was blocked and same with DHCP like you said it probably was. I allowed these Ports through but It still wasnt working but I also noticed it wasnt alowing any HTTP ports through and any loopback ports so I allowed these through and it is now working. I have a screenshot of below of the rules I have.

http://VPN KIllswitch.png

DNS Ports are 53 and 5353
DHCP Ports are 68 and 69
HTTP Ports are 80 and 443 and 8080

The ICMP Rules are the default rules