help needed with opening/closing ports

I use a program Portefolio that downloads from an ftp server.
It worked on my XP machine in June but doesn’ anymore.
I had version 3… on my XP which I uninstalled to install the latest 4.1.
The Portefolio program gives an ftp error 426.
I have been looking for a solution everywhere and always get the answer the reason must be my firewall.
I have added Portefolio to my trusted applications.
When I enter the address of the server in Internet Explorer 8 I cannot connect either.
I am told that it is a problem with blocked ports.
This is what I see in Comodo:
Network Security Policy :

  • Application Rules for Portefolio :allow all Requests (twice: once for IP protocol-In/out, once for TCP or UDP -In/out)
  • Portgroup
    HTTP ports
    POP3/SMTP Ports
    Privileged port
    I was told the program uses port 220 - I added this port to HTTP ports and POP ports but it still doesn’ work.What is the meaning of privileged ports (0-1023)?

Please look infirewall Application Rules (Firewall → Advanced → Network Security Policy).

Look up the All Applications rule. The rule for your FTP program is probably somewhere under the All Applications rule. Drag and drop the rule for your FTP program to a place somewhere above the All Applications rule. Then change the rule when needed to FTP program or Trusted Application.

The logic behind this is that rules under the All Applications rule will follow the rule set by the All Applications rule. They are subordinate to that rule; even when you change the rule it will still follow the rule set by All Applications.

Thank you for trying to help.
In Application rule the rule for the program I am having problems with is on top.
Under this come:
All Applications
Comodo Internet Security
Windows Updater applications

After reading your answer I also tried copying the FTP client rules to this application. It still does not work.

So I am still waiting for a solution.

A simple way to know if Comodo causes the problem is to close it down and retry. I did that and I still had the problem. The helpdesk of the program looked into my pc in Windows security center.
Under “protection against unwanted software” Is stated :
Virusprotection disabled
Comodo Defense plus : enabled

Is there a way to totaly disabling Comodo???

To see if the Firewall settings are playing a role give the FTP program the Trusted Application Policy. Or move down the Firewall slider to disabled.

To see if D+ plays a role first try moving down the slider of D+ to disabled. When that doesn’t help tick “Deactivate Defense+ permanently (Requires a system restart)” , reboot and try again.

Thanks to your information it appears that the problem is indeed with the firewall.
With Defense+ on and Firewall slider down to disabled I can download from the ftp server.
This is already a big help because I can just disable the firewall for the short time needed for the download but I would prefer to find a way to download with the firewall on.
My firewall is now in Safe modus. I tried moving down to training modus and restarted the application thinking that Comodo would ask me if connection could be allowed. This did not work.
If you have any other suggestions I would be glad to receive them.

One important thing I learned from all this is that you don’t stop Comodo by using the exit option (I work in Dutch : I mean - you right click on the Comodo icon and then use the last option.
So what does this do???

Hee, een mede Nederlander.

When exiting the firewall you are only exiting the client program (cfp.exe). The client program is nothing but an interface for the user that talks to the underwater part how it is expected to behave. The underwater part continues to work when you exit the client program.

With the program rule in the right place see what happens when you give Portefolio the Trusted Application policy. Does Portefolio need an open port for incoming traffic? Check the Portefolio support pages and let me know.

Hey in Belgium we also speak Dutch :wink:
Would it be permitted to explain my problem in Dutch?
I don’t understand what you mean with “With the program rule in the right place”
I have added an image my application rules as you see the application is on top.

And yes it needs to open port. I was told it needed to open port 220.
I also added an image of my port groups.
I have tried adding port 20 to HTTP ports and top POP ports but that didn’t help either

[attachment deleted by admin]

Je bent Vlaming, excuseer. Ik had “I work in Dutch” begrepen als zijnde dat je Nederlander bent. Sorry.

We can continue in Dutch if you open a topic in the Nederlands /Dutch.

I don't understand what you mean with "With the program rule in the right place"
That was just a remark about the application rule for Portefolio. Forget I made it. It does not hold any additional information for the process; more a thinking out loud. ;)
I have added an image my application rules as you see the application is on top.

And yes it needs to open port. I was told it needed to open port 220.
I also added an image of my port groups.
I have tried adding port 20 to HTTP ports and top POP ports but that didn’t help either

Thanks for the information about the port for incoming traffic.

Read the following tutorial I made. Substitute the port numbers and protocol for your situation.

To open the port TCP 1723 for example

First step is to determine the MAC or Physical address of you network connector. Go to Start → Run → cmd → enter → a black box will show up and enter the following → ipconfig /all (notice the space before /all) → enter → now look up the Physical address and write it down.

Notice that Physical address = MAC address

Firewall → Advanced → Network Security policy → Global Rules → Add → fill in the following:
Action: Allow
Protocol: TCP
Direction: In
Description: Incoming Port

Source address: Any
Destination Address: Choose MAC address and fill in the found MAC/Physical address
Source Port: Any
Destination Port: 1723

Then push Apply → Now make sure that the new rule is somewhere above the basic block rule(s) as the bottom (the block rules have red icons); you can drag and drop the rules → Ok.

Thank you for your patience.
I tried following your tutorial.
I have a problem there to start with. When I run the Dos command ipconfig /all I get severall fysical addresses
I added a screenshot without the exact numbers because I am not sure it is safe the give these on the internet
I have tried what you explained in the tutorial using the first fysical address as mac address.
I must say what you make me do is complete chinese to me.
It did not work
I have again trioed running the program with Firewall on and off.
I have copied the information the program gave me.
I have started a new post in the Dutch forum under the title “probleem met portefolio”

[attachment deleted by admin]

Let’s continue in the Dutch board. I see Ronny replied. He has much more experience when it comes to ftp connections and troubleshooting them.