Help needed CIS I am very worried that I am not protected any more

Have been using Comodo Firewall since 2003 or 2004 when I threw Norton IS out.
I am an absolute Comodo believer and tell everybody it is the best protection for your pc. I use it on my HP (XP Prof) laptop and on my Dell (Vista) PC.
Till 6 months ago I only used Comodo Firewall with another antivirus.
Six months ago I reinstalled my laptop and put Comodo Internet Security 3.13 on it.
I had a big issue with the Virus update which was always hanging around 30%. Since I updated to 3.14 the virus update is faster but still takes some time.
29/5 I decided to put CIS 4.0 on my Dell PC. I uninstalled my antivirus and Comodo Firewall with Revo and used the Comodo Cleanup tool.
When I started working with CIS 4.0 I was enchanted by the speed of the virus updates and the ease of use. Then I got a number of crashes. I have reported this in the BSOD threat. On 4.6 I updated to CIS 4.1.149672.916 and since 4 days no more crashes.
When trying to find a solution for my BSOD problem I looked around in the forum here. In some treats users say that you have to disable Sandbox in order to be protected.
I was looking around in the Comodo screen and saw that the Firewall logbook had no entries. When I was using Comodo Firewall alone I had an incredible amount of messages about IP addresses trying to access my PC and blocked by Comodo. So I disabled Sandbox. Still no entries in the Firewall logbook.
I the read about the Comodo Leak test and I ran this. My score is 110/340. I ran it with Sandbox enabled and disabled. Makes no difference. My score is a meagre 110/340.
I hope somebody will be able to help me out so that I do not have to return to Comodo firewall with other Virusprogram

[attachment deleted by admin]

two things,

when you get the first alert from comodo asking if you want CLT.exe to have unlimited access to your computer don’t hit allow, hit sandbox ( with the sandbox turned on). That should get you a result of 320-340, for some reason it varies from computer to computer but it will get fixed soon.

Secondly the firewall does not log safe applications anymore, there is no point and it does not do it anymore.

Thanks languy99

  1. Did as you proposed: hit Sandbox button and when Comodo notified that CLT was Sandboxed let it stay. Result of test stays the same (see attached doc : third test at the end)
  2. What I found in the firewall log where IP addresses trying to get into my PC. That doesn’t sound like a safe application to me. If I saw the same IP address returning I used to complain to their provider about this. I gave that up because it took too much time.

[attachment deleted by admin]

looks like you might have a bad install if it does not change at all. Try doing an uninstall using revo unisntaller set to moderate. Then reinstall, then just sandbox when it askys you the first time and back all other prompts.

I hope you mean uninstall CLS and not Comodo.
To uninstall CLT I don’t need Revo. When I read about CLT in the Comodo forum it was presented as a .rar file. Because I couldn’t unzip this (don’t have winzip) I googled the Leak Test and downloaded it from somewhere (don’t remember where). When I clicked the clt.exe file it ran the test immediately.
So it didn’t install anything on my pc and just deleting the map will be OK.
I am adding a document where you can see what I downloaded.
I might have something completely wrong???
Did you see my previous attachment with the results. Does this look normal?
Anyway I am going to use my system restore to get rid of this CLT.
Could you let me know where to get the CLT?

[attachment deleted by admin]

7zip is freeware and supports rar format.
http://www.7-zip.org/

You are the able to extract clt.rar:
https://forums.comodo.com/leak-testingattacksvulnerability-research/comodo-leak-test-suite-updated-version-t30110.0.html

But if you are really allergic to rar, you can use the zip format:

Thank you for trying to help me out.
As I said in my previous post I did a system restore because I had other issues, that I suspected to be linked to the CLT Leak test. I must have been right because after the system restore those other issues stopped.
The zip format link that Brucine posted is the one I used to download CLT. I always install programs by downloading the files to my Western Digital USB device and then opening the exe file there to install on C.
When I did this with the clt.exe the test started immediately and gave very bad results. I thought this might be because I ran the program from my external W disk so I moved the whole CLT.zip to C and unpacked it there.
The results of the test were very poor as stated in first post.
Meanwhile I began having problems with my Western Digital. I couldn’t download anything to it anymore.
The problem stopped after my system restore.
So what I did now is download the file directly to C:\Program files\Comodo.
After the download I went to this map. The CLT.zip file was not there.
I tried to download again but when I selected the C:\Program files\Comodo map the file was already there.
I add a document with screen copies.
I will continue about this problem in the threat about the Leak test.

[attachment deleted by admin]

I still remain extremely worried about not finding any entries in my firewall log. I add a screenshot.
If there is a special log for showing IP addresses trying to access your computer I think that somehow this has to be working.
I also know from previous experience that my PC was constantly under fire from external sources. My old Comodo blocked this. But I really fear it does not now!!!

[attachment deleted by admin]

Secondly the firewall does not log safe applications anymore, there is no point and it does not do it anymore.
Well I just discovered it does but it is deactivated See : https://forums.comodo.com/firewall-help-cis/firewall-log-deactivated-with-cis-4-t57510.0.html