Help! Locked out of all profiles!

Ok, the install appeared to go well until reboot when I realized I had installed from a profile without administrator rights. Now I am locked out of all profiles except the actual “ADMINISTRATOR” profile and only in Safe Mode. I cannot uninstall nor reinstall. I can access the CIS panel and System Status reports that Defense+ is not functioning properly and recommends the diagnostics utility which reports the included attachment.
Thanks for any help you can give!

[attachment deleted by admin]

Try this clean up tool in Safe mode. That should do the trick.

hi catfishman,

  1. Please explain in details how you managed to install CIS without administrator rights. The point is that users without admin rights cannot install the program, for instance the Operating System will not allow to copy files into “Program Files”, “Drivers” and “System32” folders. Apart from that users without admin rights cannot create records in the global branches of the registry. In other words it is impossible to install the program correctly having no administrator rights or without violent hacking of the system. Moreover, the installer checks the user rights and blocks installation if it is run by a user without admin rights. Or otherwise, you have some very specific conditions… Which Windows version do you use?

  2. Why particularly you cannot login under other user account? What exactly Windows is saying when you are trying to login? Which error it reports? - please explain in as many details as possible.

  3. If you think that CIS is responsible for blocking you access to the system, please do the following:

a. start the system in Safe Mode
b. open CIS GUI
c. disable all defense mechanisms: Antivirus, Firewall, HIPS and Sandbox
d. reboot the PC

After the restart CIS should not block anything (if it was installed correctly).

I have run the cleanup script twice as directed and still cannot log into any profile except ADMINISTRATOR in Safe Mode.
I have tried creating a new profile, and when I try to log in I get:
App failed to init (0xc000005)
Prompted to hit OK
Then blue background (not blue screen of death, just blue)

The original profile (one I installed to without admin rights) goes as follows:
Found new hardware.
Must be member of admin group
Ethernet controller
Username and password prompt
I choose administrator
Prompted to OK
Welcome to found new hardware wizard
Clouds and grassy hill background
Nothing else happens.
Ctrl-Alt-Del brings up task manager.

I do not care about saving any profiles, I just want to create one that can operate outside of Safe Mode.
Thank you for your help!

I am using XP sp2

Have you tried to completely disable CIS in the Safe Mode?
The symptoms you mentioned resemble those of a computer infected with a virus or rootkit (Windows Explorer cannot start, etc…). This might also happen because of incorrect installation of CIS, that’s why I recommended to disable it.
Was the CIS installed fully and correctly? I am embarrassed and worried to hear that you managed to install CIS “without administrator’s rights”.

Please also let me know whether any other security product (other firewall, antivirus, HIPS-application, etc) was present on your computer?

I was running Avira Antivirus, Superantispyware, and Online Armor Firewall. I was intending to disable Online Armor once CIS was installed.
No, CIS did not appear to complete the installation. It requested a reboot, then could not complete due to no admin rights. That is when the trouble began.
After running the Cleanup Script there seems to be no trace of CIS other than a leftover desktop link to nothing.
I am currently in the Administrator Profile in Safe Mode and everything seems to work normally, (except what cannot happen in Safe Mode).
Am I now looking at a Windows reinstall?

ok, try this:

  1. login in the safe mode
  2. go to the system drivers directory: c:\windows\system32\drivers
  3. find and delete next files: cmdguard.sys, cmdhlp.sys, inspect.sys and cmderd.sys
  4. reboot
  5. try to login normally
  6. using the administrator rights go to the Control Panel and run CIS uninstallation

This should help.
And never install two antiviruses on the same OS :slight_smile:

These files are not there. I assume because of the cleanup script I was given?

Yes, maybe
But if you have not these files, these is no COMODO firewall or antivirus installed, so they cant block your system

I deleted all driver files for other antivirus and firewalls that I could find. Now I can log in to my profile.
I reinstalled CIS this time with admin rights and it is working fine.
Thank you for your help.