Help! I've got DLL hell!

Hello, fellow human beings. Thank you Comodo, for this software is truly awesome… except when it’s not. :cry:

Whenever I try to open the Comodo CIS settings window, I get an error which reads:

The procedure entry point _except_handlr4_common could not be located in the dynamic link library msvcrt.dll

I can safely ignore this message, but I then get a second message:

The procedure entry point GetProcessHandleFromHwnd could not be located in the dynamic link library OLEACC.dll

The first error appears 3 times, and the latter appears 4 times.

If I ignore these errors, I can get into the CIS window. However, when I try clicking on the “settings” button, I get those same errors again, the settings window appears for a few seconds (while my computer lags), and the the settings window closes.

I’m running Windows XP (yes, you read that right, WINDOWS XP. No, I’m not going to “upgrade” this particular machine to a newer version of Windows)… so naturally I want to harden the system as much as I can. It’s difficult to harden anything if I can’t get into the settings. Due to some previous issues, I’ve just been forced to re-install Windows. (Side note: Did you know the servers needed to activate XP are still running?) That said, Microsoft’s updates are being installed as I type this. Perhaps one of those updates will help. (Although I kind of doubt it).

I’m running CIS 11. I’ve tried removing and reinstalling it, but that didn’t help at all.

On top of which, if CIS can’t open it’s own window without crashing… suffice to say that I’m not sure how much extra security I’m getting out of this program. What if the HIPS isn’t really doing its job? Likewise for the firewall.

PS: Just before posting this, I realized that if I close all CIS windows, I can right-click the tray icon, and, after I click my way through the errors, I can indeed get into the settings. But it would still make me feel better inside if these errors could be resolved. I do believe these errors are bugs on MY end, since other programs (like Explorer++, and a few old video games) are also affected.

Another possibly-related issue: while attempting to post the above, I decided to set my firewall to Custom Ruleset. My browser then lost the ability to access the internet. I think something is preventing CIS from displaying the popup notifications, in which the user usually grants/denies internet access. There was also an issue with a notpad program (which I used to copy/paste the post in case I couldn’t post anything with this browser, and needed to switch browsers). Said program refused to launch, giving me an error which read “access denied”. I fixed the issue by disabling HIPS. I guess I’ll have to go into the settings and start manually adding rules for the firewall and HIPS.

Since I prefer for the system to ask me what to do if it encounters a “virus” (darned false positives!), I set the program to never quarantine anything without asking me first. However… there’s no way it’ll be able to ask me first! Gah!

Hi Halo117Nachos,

Can you please Export your current configuration by following this guide and uploading in any online storage and share us the download link.

Can you please check your popup alert settings in Advanced Settings-> Firewall → Firewall Settings → Do not show Popup alerts

Thanks in advance.

Kind Regards,

OK, here’s a quick update: I’ve got some MS updates installed, and the oleacc.dll error has dissappeared. However, the msvcrt.dll error remains. CIS also tried to show me a popup, but then weird things happened Somehow, the popup appeared in two parts of my screen. I’ve attached an image to show what’s happening*. Shortly after I took that image, the popup disappeared.

Another thing, If I press Alt+TAB, I can see a CIS item in the list of menus. However, if I try to select it, I don’t see any window appear. This window also does not appear in the task bar. Maybe that’s supposed to be the popup?

@PremJK: TBH, I feel like the “Do not show Popup alerts” setting defeats the whole purpose of setting the firewall to “Custom Ruleset”. As for exporting/uploading my configs, I can’t do that at this moment, since I’ve taken the computer offline (I’m posting this with a different computer). So I’ll have to post that later.

*I tend to be a bit paranoid about privacy, so I blurred parts of the picture. However, you can still see the weirdness.

OK, more updates. Although I’m still getting the msvcrt.dll error, I’m no longer having issues with popups… except that each popup is preceded by the aforementioned dll error. Err… when I was typing this post, I got a popup which was nothing but the color white. I couldn’t read it, much less respond to it. It froze my browser. The message eventually disappeared, allowing me to make this post. Maybe CIS was restricting itself?

Also, here’s the config export file.