HELP is silense repetitive messages because of csc (ASP.NET) compiler

I am TOTALLY ANNOYED by the repetitive questions such “csc.exe” is a safe application … It is about to create a file in “C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files …”
bla bla … “Remember my answer” Total lie … When ever I compile I have to press 10-15 times the allow button…

If there is not a solution to get this annoying messages turned off, I will DEINSTALL COMODO Firewall. csc is safe …and I have tried to find settings to silence these verbose messages … I FAILED …

Please help


Please stop with the caps. Can you provide more info such as what is your OS? What version of Comodo are you using? What do you have D+ set to? Can you provide a screen shot of the alert? The alert simply means that D+ is working and protecting you. What exactly are you doing each time the laert pops up?

Thanks for your quick reply.

I have a WinXP latest SPs; latest Comodo Firewall Professional ( D+ security level is set to “Clean PC Mode”. I compile (build) or debug an ASP.NET website in Visual Studio. I start the process and messages of the type as in the screenshot attached appear. Always in the same sub-directory…


[attachment deleted by admin]

Well 2 things. Why did you get rid of “More Options” Try clicking on that and making it “trusted” Also put D+ in Safe mode. The alert is different each time probably cause its a different temporary folder each time.

You are right with the different directories. I have remove the additional options in the message interface, because it doesn’t help me … As you can see in the attached screenshot.
Regarding higher D+ security level – didn’t help at all.
These message boxes are extremely annoying … as I try to do some other work during the compilation in the background.
My philiosophy: … security features should do its job in the background and only in a few exceptions bother the user.


[attachment deleted by admin]

CFP rules are configurable.

You can keep csc.exe in custom mode by editing its \access rights\protected file folders\Allowed list adding C:\WINDOWS\Microsoft.NET\Framework*\Temporary ASP.NET Files* or a similiar rule (an * will work too).