Help - IceDragon will not install

I downloaded IceDragon from the official Comodo website. But when I double-click on the installation program, it opens up only briefly (shows a message: “Verifying installer” that only reaches ~80%) and then quits. I opened Task Manager and saw that the executable’s listing disappeared after a few seconds. No error message was given, and Windows Error Report (werfault.exe) does not show up in Task Manager either.

What could be causing this problem? I even tried moving the installer’s executable to the root of the C: drive, renaming it to a small filename (c.exe) and double-clicking from there. Still nothing. Even tried running the program from the command shell. Nothing. Just a brief flash of the “verifying installer” alert on the screen, before it disappears completely.

Using Windows XP SP3 (yes, I know, I should upgrade, but can’t yet). It’s a heavily “nLited” version with IE removed. “Regular” Firefox installs fine (has no relevance to IE), as do other forks like Pale Moon and even old-as-dirt Netscape 9. What’s wrong with IceDragon? Why won’t the installer open up?

Hi and welcome newuser123,
Try downloading the installer again, in case the current installer is corrupt from a faulty download.

Kind regards.