HELP!I think Comodo locked me out of my PC!!!

Hi. Im a noob to this stuff and I think Im WAAAAY over my head. I’ve had Comodo Firewall Pro installed on my PC for at least 4 days now with no problems. My only tiff was that it has been"learning" my computer the entire time. But i looked passed that. I went to download a simple Jigsaw Lite freeware file and tried to install it. Comodo asked if I trusted the program to install it every step of the way like it’s supposed to. But after the program installed, i clicked on it and it tried to install itself again and Comodo asked me again if i trusted the program. Well I X’d out of the second screen and another screen popped up and asked me what type of application it was. Instead of clicking “Installer or Update” i clicked “Isolated Application”. The window closed and I tried to open the application but an error screen saying “Windows cannot access the specified device, path,or file. You may not have the appropriate permission to access the item” popped up. THIS IS NOW HAPPENING ON ALL MY APPS! I can’t open anything. I can’t even do a System Restore or turn the computer off. Someone please tell if and how to fix this problem. I will be in your debt. Thank U.

Help!!! Me, too! Exactly the same situation. How can I fix it?

I had the same issue with Vista sp1 twice, last time was today. It happen after installing a program. I had to uninstall Comodo firewall to fix the problem.

This problem was so bad that it wont let you restart your computer, (Windows thinks you don’t have access ???). I had to log out of windows then use the restart button.

To uninstall, you need start Windows in Safe mode (press F8 after the computer boots). Thats the only way I was able to get my system back. I’m not planning to install this Firewall again, atleast not for a few months until this is resolved.

About my system:
clean install of Vista Home Premium 32 bit with SP1, AVG free antivirus, then installed Comodo. (in that order)

ComodoFirewallP_Setup_3.0.20.320_XP_Vista_x32

What exactly do I do when I manage to boot in Safe Mode?

My system is running Win XP Sp2.

You will need to go to the windows add/remove and remove Comodo, then boot and reinstall it. This usually happens when someone accidentally blocks and remembers explorer.exe, which launches the applications, or wininit.exe, which launches the windows system programs. CFP really should have a method to undo this, but don’t know of any except to remove and reinstall. The popups can be confusing enough for new users to do this occasionally.

Thanks so much. That fixed it. While I’m hardly a new computer user, I am new to Comodo. Perhaps in the future the wording could be changed so this doesn’t happen. Or maybe make it not an option to shut off access to any apps? ;D

Thanks again. (:CLP)

i had the same problem! my laptop just arrived this morning, i’ve barely had it 6 hours and i thought i’d broken it already! phew, thanks for putting up the solution!!

Here’s something that worked for me.

  1. Boot into safe mode
  2. Run Comodo
  3. Click the “Defense +” icon
  4. Click the “Advance” button
  5. Click “Computer Security Policy” link
  6. look for %windir%\explorer.exe
  7. set it to “Trusted Application” if it is not (mine got set to “Isolated application”)
  1. Click “Apply”
  1. Exit Comodo
  2. Reboot

You don’t need to boot into safe mode to do this:

  1. Go to Defense + > Advanced
  2. Click “Computer Security Policy”
  3. Look for the application which you “isolated”
  4. Click on “Remove” OR If you have seriously messed up click the purge button. I don’t know what it will do but me thinks it will clear the list :slight_smile:

Have fun.

I have similar problem but can not access the Comodo program, nor can I restart in safe mode, F8 - have started a new thread on this variant of the “isolated”-problem:
https://forums.comodo.com/help_for_v3/crash_no_rights_after_saying_yes_to_isolated_f8_reboot_not_possible-t24664.0.html