HELP I gave the wrong answer and now can't open program with Defence+ on

I’m a new user and having a frustrating time.
I clicked the wrong answer on a Defence+ screen for one of my major programs and now can’t open it or any MS Office program with Defence+ on.
The frustration is that I can see the applications in the Defence+ log but I can’t find anywhere to change the setting for the program.
I’ve added it to Firewall Trusted Applications and to My Own Safe Files in Defence+ but it still won’t open with Defence+ running.
I’ve tried shutting down the computer and reopening.

My limited experience with Comodo on another computer is that Comodo doesn’t pass its own Leak tests without Defence+ operating so I may as well go back to my old firewall if I can’t get this sorted.
I can see where to change Firewall settings. It’s the Defence+ part that doesn’t seem to allow you to change particular answers.

Go to Defense+/advanced/computer security policies and either edit the permissions for the blocked programs, or delete them from the list for another chance at the popups. The procedure for changing D+ settings is analogous to that for firewall settings. :slight_smile:

That sounds logical except the program wasn’t listed there. I looked and looked. The program was Legacy - A Family Tree program based on Access - which is why I guess it blocked all Office Applications as well without asking. They weren’t listed either.

They were only showing in the Defence+ log which doesn’t enable you to edit - just informs you that they’ve been blocked.

I’ve solved by uninstalling and reinstalling.

If they are not already there, you can add the programs to the D+ list with “allows” by going to computer security policies and then to add/select. What programs did show up as blocked in D+?