to reenable the application that i had block it

i had set these rules:

network rules:

allow TCP/ UDP in sourceIP =anyIP anyPort to destinationIP (my ip) on port 27189

and for Application rules (bitComets):

allow TCP/ UDP in sourceIP =anyIP anyPort to destinationIP =myIP on port 27189
allow TCP/ UDP out sourceIP =anyIP anyPort to destinationIP = any anyPort

these rules work nice for me for more than half year since i used comodo firewall, untill i accidentally block bitComets when comodo firewall pop up on one day… the bad new is since that day, i fail to download anything with bitComets and it kept telling me connecting to tracker error but all the tracker are ok at the same time on another PC.

Do i have any way to reset the setting besides uninstall it??

thanks for reading…

If you block something by accident, then you only need to review all blocks in both the Application & Component Monitors. Probably the best strategy is to delete any blocked entries for your target application or any unknown entries & to allow CFP to re-prompt for them.

Hint: Check CFPs Log to see where the application is being blocked.

i had tried but it still not worked for me. I wonder why comodo firewall does not allow us to view those application list that had promt to us and we had set it to remember the setting for that particular application…

anyway, thanks kail… i will reinstall comodo firewall, it was really un userfriendly, but what can i asked for more…it a lifetime freeware… :-[

It should do exactly that. If you blocked something (remembered) then you should have a corresponding block entry in either the Application Monitor or the Component Monitor. Checking CFPs Log should tell you exactly which Monitor is blocking bitComet & what specifically is being blocked.

thanks kail, just forget about the post, i will reinstall it.

I have run into the same problem, with a different application. I told it to block wmplayer.exe from accessing the net (I dont use wmplayer as my default player generally), it came up a second later with a message that wmplayer.exe was trying to use explorer.exe to access the internet through ICQ, thinking wtf I blocked it. Now I can’t use ICQ without disabling the firewall, there is no blocked application in any of the windows (I even deleted ALL applications from the list, and clicked on every “reset to default” button I could find), and I have also tried adding the program as a trusted application (still blocks it, still logs that its blocking it, but has no rule that I can find anywhere except the green trust this application rule. )

So how do I fix this and/or nuke everything back to defaults?

Hi Corruption, welcome to the forums.

Check CFPs Log. If CFP blocked something then there will be a corresponding entry in the Log. These entries will state exactly which section in CFP blocked it & where to look.

The log shows that “Application Monitor” is blocking ICQ, but looking in application monitor there is no rule blocking anything… I can even create a rule that says allow icqlight, and it still blocks it. somehow I managed to create an invisible rule by clicking block as I reported.

Tomorrow I’ll try uninstalling/reinstalling.

Thanks for your reply.

That is very strange. If ICQ remains blocked after a reboot the you should report it to Comodo Support. Sorry I couldn’t help.

I have been using Comodo for less than a day and noticed than there is a situation where one application uses OLE or sum such device to manipulate another application. When the pop-up shows for this there is nothing in the GUI to show that you have asked the Firewall to remember the event.

I use Windows Blinds and got a rash of these when I changed the skin.

On checking the registry I note a whole section

HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Personal Firewall\AppCtrl\IPC

where these remembered events are being stored.

There should be a way in the Main GUI to access these and allow them to be view, edited, or deleted as I think that is what is probably causing all the confusion here.

Hope that helps a bit…

I agree 100%.

It is also annoying/unsettling to not be able to see the white list of allowed applications.

Comodo may be very secure with o-t-b settings but it is lacking in useability and IMO very buggy.

Until a substantially improved version is released (3.0?) I will go back to sygate + cyberhawk + hips and take my chances!

Thank you so much!

Went to HKLM/Software/Comodo/Personal Firewall/AppCtrl/Apps/ found the subkey for ICQLite and set […]/Flags to 0.

Its working again.

Deleting the list of applications from within the program should have cleared these IMO, but at least its working now.