HELP: GUI still slow as heck!

ok I’ve been using CFP since it’s been released as final. However even after it’s latest update 3.0.17.304 I’m still experiencing a delayed GUI. I can barely change my settings either because the GUI is distorted or it’s just taking too long to appear. Someone plzzzzz help. (:AGY)

Hi Jack,

Do a google for “Process Explorer”, download it and run it. Filter on CFP.EXE and it will display all the process that it is interacting with. The one with the highest reading is what is causing the problem.

There appears to be a growing list of applications that can cause this, but the fact that this only occured on your system after upgrading to 3.0.17 is a worry. Hopefully any details you can divulge wil help the dev team nail it down.

Let us know what you find.

Cheers,
Ewen :slight_smile:

Exact same problem here, didn’t happen with any of the previous versions. It is so slow that for awhile I believed it had crashed and have rebooted a number of times when this has happened as I thought CFP had frozen and could find no other way to regain control! I have even tried a clean install, as I thought maybe something had gone wrong during the update from the last version.
Last time it happened (after reading this post) I deceided to just wait it out - after a while CFP started to respond again (probably 3 - 5 mins!). While this is happening the CFP windows are either blank or mixed up like there are two windows blended together. :frowning:

Another thread about that issue:
https://forums.comodo.com/help_for_v3/slow_user_interface-t18054.15.html

Seems like different things can cause the slow GUI. For me its ATI Tray Tools, the raphook.dll installed by ATT to be more precise.
Just close the programs running in the background on by one and you might find out what causes the issue for you.

no, no, no. This problem has been occurring since my first install of CFP 3 which was the first version that was released as final, so my problem is not new by any means. Also what do you mean by “filter CFP.EXE”. I see no option within the process explorer that allows me to “filter” a process. After reading a few posts I can see that I’m not the only one with this problem. While my problem is not as severe as lobster’s, it’s still makes CFP barely usable.

If this helps any I am running the free version of McAfee provided by AOL, Webroot Spy Sweeper along side CFP 3 with D+ enabled on a fully patched Win XP SP2 machine.

I can confirm this problem ever since the release of 3.0. I thought it was Windowblinds but even with Windowblinds unloaded it still happens. I got use to it but actually its rather annoying.

Good Day,

A friend had the same problem with ver 3.0.16.295 (before this he was using ZoneAlarm Pro)…
We were able to resolve it by uninstalling his Anti Spyware application (ewido/AVG Pro)…

Best wishes,

Roberta

CFP 3’s GUI has always been annoying slow for me since its very first release.

It is funny to come back here to comodo’s forum once in a while, and still see people posting on the same old problems.
There isn’t just that one other post, but there are a lot more posts on the slow GUI problem. Yet there wasn’t ever any reply from comodo’s developers; something like: “yes we are into it, and it will be fixed soon …”.

I stopped using CPF long time ago for that problem. But I wish you guys much luck with it; maybe it will be fixed for 3.0.66. or 3.2.0 or whatsoever … (:CLP)

Using 304 on an old athlon XP 1800+ running XP SP 2 (NOT updated) and it is snappy as hell. Then again 277 and 295 were as well. I find no lag in the GUI what so ever, either that or all my programs are slow and I can’t tell the difference :stuck_out_tongue:

Always been slow for me. Hopefully one day it will be fixed. Till then I am looking elsewhere.

I’m really surprised at how many people are experiencing this problem. Since this bug has occurred ever since the final release of CFP, why hasn’t comodo looked into this yet? I have yet gotten a chance to use CFP to the full because I have to put up with this slow, distored GUI problem.

and I’m really surprised about how many people think the Comodo development team are doing nothing about it. :wink:

They are aware of the problem, but the most likely cause of the delay is reproducing it.

Consider how many thousands of installations have been done of CFP V3 and compare this to the quantity experiencing the slow down. Following on, consider how many of the affected people have contradictory environments, with little or no commonality between them, other than the GUI slowdown.

To make a rabbit stew, step 1, get a rabbit…

To fix a software problem, step 1, identify the root cause…

I believe they will track the root cause down, but when remains the question.

Please bear with them while they try and get on top of it.

Cheers,
Ewen :slight_smile:

Want to reproduce it? ???

Intall XP + ultramon (2.7.1) + CFP, … and voilà.

even no need for a clean PC; works also pretty fine in an VMware virtual machine.

Was posting that already ages ago … :THNK (:KWL)

And the reason it can also happen on systems not running Ultramon is where the waters start to get muddy. This is what I meant by some/little/no commonality.

On one of my systems, it runs slow, but I this particular instance is a CLEAN box with just XP on it, not even any updates run, just XP SP2. This would seem to indicate hardware, not a software conflict.

It very well may end up that there are several root causes, all presenting with the same symptoms, but these are the things that can only be proved afer exhaustive testing, which is where we find ourselves now, AFAIK.

Cheers,
Ewen :slight_smile:

I’ve tried three versions of v3, the last one being 3.0.16.295. All had the slow GUI, plus cfpres intermittently not loading at startup, and ctfmon hanging at shutdown (though I did find a work around for that on these boards). Each time, I went back to v2.4 (thanks to Acronis for making that easier).

I haven’t given up on v3; I’m confident it WILL be a great program for me one day.

Hmmm… I’m using SAS Pro and have wondered if that might be causing some of the problems. Thanks for posting your solution and reminding me! ;D I’ll try uninstalling SAS first the next time I try CFP v3.

(V)

Why do you think we would spend so much money in making this product and give up on small bug?

yep makes no sense.

As Ewen said, as long as we can re-produce bugs we fix them pretty quickly. Also, reproducing on one machine is no guarantee that it will re-produce on other.

As always, we are on it.

Melih

Finally some feedback from the STAFF. :BNC

Thats what I was really missing: a message to all that poor problem posters to let them know that comodo is actually working on it.

BTW: Wasn’t there once someone recommending something like a public list of bugs that are known/confirmed by comodo. That would make life much easier here in the forum, because people wouldn’t have to post again and again on the same problems.

Luckily this bug can be even reproduced in VMware (at least for ultramon). So the hardware setup shouldn’t be the problem. (:NRD)

:slight_smile:

we have the bugzilla visible to mods only. so that they can put the bugs in etc…

just to be sure, can u pls send me a link to all the software (including their version numbers etc).
so that we can try to replicate.
thanks
melih

ultramon 2.7.1. + CFP; thats all

VMware I guess you guys know; it is a virtual machine. But it has nothing to do with the bug, just that it can be reproduced in any default VMware XP installation (by installing ultramon 2.7.1. + CFP).