[Help] FTP - 425 No data connection


I’m using windows XP SP3, before installing CIS, I can ftp via c:\windows\system32\ftp.exe without any error, but after installing CIS the error message is attached, got error 425 - no data connection. If I turned the CIS firewall off, the ftp worked fine ???

It’s useless even I set ftp.exe to FTP client or trusted application in CIS → Firewall → advanced → Network security policy and added it as trusted application in CIS → defense+ → advanced → comupter security policy. Can anyone help? Thanks!

[attachment deleted by admin]

BTW, I forgot to mention that the ftp ran ok without any problem in my old computer which had CIS 3.11 installed…

Does anyone help? Thanks!

I removed CIS 3.13 and installed the old CFP 2.4 only then test the FTP, it worked fine!
But I upgrated it to CIS3.5, it’s not working again…

ftp>get a.txt
200 PORT command successful.
425 No data connection

Any Comodo master please help me!!! :cry:

Let me ask the other mods.

Normal “Active” FTP needs incoming traffic from server port 20 to you “any highport random” i think your global rules are blocking this traffic.

Please read this to better understand how FTP works:

Please use a FTP client that supports Passive FTP that way you can make FTP and port numbers behave under your control. (No incoming connection setup).

This post here is about the same issue:

Hi Ronny,

Thanks your suggestion. I just use the ftp built in XP, entering passive mode, no luck still… (see attached).

My old computer has same installation - CIS (with Comodo Firewall) and ftp works fine, I just don’t get it why same installation in new computer that not working… I have compared 2 PCs the firewall settings are all the same… the ftp.exe settings are same as well.

When you said “Global rules” may block the traffic, could you tell me where so that I can check? Thanks!

[attachment deleted by admin]

The windows command-line ftp.exe does not “really” support passive mode as we also saw in the packet capture of the other post is referred to, the user switched to an other command-line ftp client that does support Passive FTP.

Well, I have tested WS_FTP, not working… :cry:

Have you verified that you used Passive FTP?

How are your global rules and application rules for WS_FTP?

Hi Ronny,
I have ncftp solution now, so forget the ftp build in XP…
Thanks anyway, you taught me a lot! :slight_smile:
BUT STILL, I don’t get it why 2 machines with same setting but one doesn’t work ???

There must be some difference between the two :wink:
Good to hear you got it fixed :-TU

Great thanks!!!