Help: Firewall is blocking the connection sharing

I have a desktop PC connected to the Internet which shares the internet connection with the local network.
A netbook PC is connected to the (wired) local network.

Unfortunately the firewall on the desktop PC is blocking the access to the internet for the local network.
For example when I do

nslookup www.yahoo.com

on the netbook PC, the Comodo firewall on the desktop pc shows that the UDP request on port 53 is blocked (see attached picture).
I checked the option to make the desktop pc a computer an ICS gateway.
Also I checked all the rules to see which one is responsible for blocking the access, but I couldn’t find any.

Can Comodo firewall show me which rule is used when some packet is blocked ?

Thanks in advance for your help, this is driving me crazy since it worked just after I installed Comodo, but now it doesn’t work anymore, even though I didn’t change anything.

This is the picture: the black rectangle just masks the address of my ISP’s name server.

[attachment deleted by admin]

This is the configuration file exported from Comodo.

[attachment deleted by admin]

Something bad happened to the text file during the upload: rectangle characters appeared in the file.

Here is the file again, in an archive.

[attachment deleted by admin]

Hello Softdown;

Does Your Problem Still Exist After you Follow this thread?

Kind Regards

Hello Jacob,

I did two the two things mentioned in that thread, but the problem remains.
Here is what I did:

  1. I added the address of the other computer (netbook) that I want to connect to the internet (192.168.0.10) to the network zone LAN2:

-see image Network Zone.png

  1. I added to svchost.exe the rules for the “System”:

-see image App Rules.png
-also see image Global Rules.png

Unfortunately when I do “nslookup www.yahoo.com” on the second computer, the request gets blocked like before.

I would like to understand which rules is responsible for blocking the requests so that I can remove or alter it.
As you see, my rules are quite simple, so I cannot figure out which one might be responsible.

Thanks for the help.

[attachment deleted by admin]

You have no rule set for svchost.exe. Give it the Outgoing Only policy. Does that fix it?

Thanks EricJH, that solution worked.

However, this rule seems too permissive for svhost.
Is there a more specific rule which achieves the same thing ?

Hi,

What about making a rule like this:

Allow UDP 53
Source: 192.168.X.0 (255.255.255.0) (the network where the netbook is in)
Destination: Any

That rule will allow all request to DNS Servers on the internet, and then, you´ll be able to surf

Thanks, that’s what I did in the end.