[Help] Firefox 2.0 can't render my website's form [Resolved]

Dear all,

I’m at my wits’ end here. I’m troubleshooting my website. It works fine with Fx 1.0 (and some says also with Fx 1.5), IE 6 (don’t know about IE 7), but it failed to render properly with Fx 2.0.

If you want to replicate the problem, here’s the instructions:

  1. Go to www.jobitcom.com
  2. Click on “Posting Lowongan!”
  3. Enter member ID “tes” and password “tes” (without quotes), click “Login”
  4. Wait while it is logging in
  5. Click “Post a New Job” (near the bottom of the page)

After step 5, Fx1.0 and IE6 showed the form, but Fx2.0 did not. You can see some screenshots through the following links

How it looks like with Fx1.0

How it looks like with IE6

How it looks like with Fx2.0 (notice that the form does not show)

(Sorry for the indirect links; I tried uploading to imageshack to provide thumbnails but the upload keeps failing)

(Another apology for the slow links; the server is located here in Indonesia, and the connection to other countries sucks)


Aha! I think I’ve found out what caused this:

It’s AdBlock Plus, blocking the URL for the script, which happens to be located at http://www.jobitcom.com/advertisers/index.php … apparently ABP triggers on the “advertisers” word.

I disabled ABP for that page… and all is well! Wonderful!

I think I will restructure the site to change “advertisers” to something else that ABP will not block, and hack the .php scripts accordingly.

Sorry for taking your time! Much gratitude to all who’ve tried to help!