Help finding out what is blocking outgoing connections on Custom ports

Hope someone can help. As I posted earlier a software I still use Qnext is still working but the Qnext staff has deleted all online support files and have directed their energy to Qnext file sharing via Facebook.

Almost all of the Desktop program (Windows version) still works and connects to their sign on server. Facebook does not, not sure what else does not.

I “almost” have a perfect connection when using the Qnext connection wizard at home. There is a light next to your buddy name and Green is the best connection.
When running the Connection Wizard just before the end it gives a status report and it always says Outgoing connections on custom ports are blocked. Everything else reads Good,

This is what I am trying to solve ? What is causing the Qnext Connection Wizard to report blocked outgoing connections ?

Being old software I ran Windows7 troubleshoot compatability. I also added 2 exe files Qnextclient.exe and Qnext.exe to the Allow list. What is funny is years back I only needed to be concerned with the Qnextclient but now Qnext.exe kept popping up a Behaviour Blocker alert that I kept saying allow to but finally got smart and added it to the Exclusions list.
2nd question, to allow child processes in the Exclusions list is the green check mark on or is the X on ?

Oh earlier in running the Qnext Connection Wizzard I discovered clicking on Stealth Ports allowed some of the other connections. When does Stealth Ports need to be clicked on and is there a need to do it more than once ?

The Connection Wizard besides Automatic also has a Custom setting for Port Forwarding and Proxy settings. Not sure how to set these up. At home piggy backing on a neighbors signal. At the library they use Coova for you to agree to before you login.

I have checked the logs after running the Qnext Connection Wizard and do not see anything blocked.

Thank you for your suggestions and help,
UncleDoug

Can you post a screenshot of your Global Rules and let us know what ports Qnext needs to have open for incoming traffic?

What policies do you have for Qnextclient.exe and Qnext.exe in Application Rules?

What do you mean with “I also added 2 exe files Qnextclient.exe and Qnext.exe to the Allow list”? Do you mean you added them to Trusted Files list?

Eric,

Can you post a screenshot of your Global Rules and let us know what ports Qnext needs to have open for incoming traffic?

There are several ports Qnext uses. I was trying to find out what was blocking Outgoing Connections on Custom Ports when running the Qnext Connection Wizard on Automatic.

To run the Connection Wizard Qnext restarts and checks Port 5235 for incoming traffic.
The Custom Ports it then checks are 67, 227, 250, 86, and 5235

I am not sure what to do as I do not know how my neighbors router is figured, nor do I know how the library router is figured using Coova

But for Custom Direct the TCP ports are 443,80 and the Conference Connection uses Port 5237 UDP

Forward 80 Type TCP to IP 10.1.0.71
443 Type TCP to IP 10.1.0.71
5237 Type TCP to IP 10.1.0.71

Local Area Mask 255.255.255.0

As I said since I am not sure what I am doing I only use the Connection Wizard and Automatic, and not the Custome Direct, Port Forwarding or Proxy.

At home the Green Light next to my buddy name shows that I have the best connection, but the window before Qnext restarts shows Outgoing connections blocked on custom ports.

I had asked 2 questions earlier

  1. Does the stealth button need to be clicked more than once, and if so when.
  2. In the Behavior Blocker there is an Exclude Child Process Is the Green checkmark to allow the Child Process or the X

I cleared the logs and ran the connection wizard with NO logs showing.

Hope these attachments are what you wanted.

UncleDoug

[attachment deleted by admin]

Assuming the Connection Wizzard is answering correctly I believe the problem is more than likely the router(s) through which you are trying to connect. Easiest way to establish if the router is the limiting factor is to temporarily disable the network firewall. If with the firewall disabled the problem persists then the problem is upstream with the router. Please double check that Windows Firewall is disabled (the CIS installer tends to forget to disable it).

It makes sense when troubleshooting to see if adding the Qnext executable to the BB exclusions. For the sake of being complete you could try adding the Qnext executables to the exclusions of [urlhttp://help.comodo.com/topic-72-1-522-6307-Behavior-Blocker.html#shellcode_injection]Detect Shellcode injections[/url].

For the moment my best guess is that the router is in the way. But we’ll see.

The Stealth Ports Wizard allows to choose between two ways of handling incoming connections. You have enabled the option to be alerted for incoming alerts. This is a convenient function when you are on a local network behind a router . It allows to allow or block traffic from other computers on the network, or incoming traffic from the web through an open port on the router on the fly.

The other option of the Stealth Ports Wizard is to have all incoming connections blocked silently. This is useful when your computer is directly connected to the web through a modem (no router) or when you travel with your laptop (in this case it makes sense not to trust each local network you connect with). I always use block incoming connections as I don’t want to trust my house mate’s computers… :smiley:

Either method works. It boils down to personal choice which of the two strategies to use.