Help False positive starcitizen.exe

Every time I try running the game Star Citizen, Comodo seems to ‘forget’ that I previously instructed it to ignore this in the future. Every time I instruct Comodo to ignore this false positive in the future and to add it to my trusted applications, the next time I go to run the game again, Comodo again blocks the program from running properly. Why does it keep resetting and how do I add it to my trusted application permanently?

What I did so far:

  1. I added “starcitizen.exe” to the trusted applications by going into advanced settings, rightclicking the file and adding to the trusted applications.

  1. Each time the Comodo pop-up occurs, I click on “Add to trusted applications”.

But then the next time I go to run the program, the same thing happens again - even though I keep adding it to trusted application both manually AND in the pop-up every single time.

  1. I tried running Comodo in Game Mode, this prevents the pop-up from occuring, but still crashes the program.

  2. Return to step 1

I think this is something about digital signing rather than a false virus detection, so if this needs to be moved to a different sub-forum, can a mod move this thread to the proper forum?

Thanks in advance!

Short of disabling or uninstalling Comodo altogether, I have not found a solution so far :frowning:

Hi Caebron,

You should submit the file here.

OR/AND

You could add the vendor manually to your “Trusted Vendors List”. You can find more information here.

Thanks for the reply!

I attempted your suggestions, qmarius, and here are the results:

  1. When I attempt to whitelist the file, Comodo returns with an error message stating the file size has been exceeded.

  2. When I try adding the program to the trusted vendors, it says it is unable to do so:

:cry:

Hi,
When you encounter a False Positive (=FP) or a suspicious file please follow 1 of these 3 ways so it can be resolved as quickly as possible.
Thanks.

Kind Regards.
Erik M.

  1. Write in the title the program/file that is detected - Check

  2. Provide the name of the FP, for example : Heur.Packed.Unknown - “starcitizen.exe”

  3. Provide a link to the site of the program - https://robertsspaceindustries.com/

  4. Provide the number of your CIS database - unknown?

The other methods don’t work for me as described in the previous posts.

Forgive me for saying so, but all this seems like a heck of a lot of trouble to go through just to get a valid program to run :frowning:

Hi,

Just upload the file here and post the link in this topic.

http://camas.comodo.com/cgi-bin/submit?file=9d1f4f763c747276bac9656cdc244ff8448de1ddde95502705d7a5ef77de64e2

Do I need to do anything in addition?

And what steps do I take now for the program to run properly? Just use something else until the file get’s whitelisted?

Again, thanks for the help!

Please, check this post.

Hope it helps. :wink:

I’ll be honest. I really appreciate your help (!), but I’m not a very technical person and I admit this is all way over my head. I have no clue what I am doing and I’m afraid I may have crippled Comodo by more or less making haphazard guesses when changing the various settings. For all I know I completely gimped Comodo at this point.

EDIT: fwiw, I resolved the issue by uninstalling Comodo. Perhaps not the best solution but at least it works :frowning: This may seem a bit radical but I really can’t waste more time on this issue as I am becoming increasingly frustrated >:(

Thank you for your willingness to help though, and sorry this is over my head.

Hi,

This False detecting will be fixed in next database update.
And You always can activate “Game mode” in CIS.
When it will be fixed and checked we will inform You, and hope You install CIS again and check it too, because You help us to make CIS better.

Kind Regards,
Erik M.

As described above in step 3, Game Mode was one of the many things I tried which didn’t work.

Hi Caebron,
Note: For use with 100% trusted files only.
Add the file to the Behaviour Blocker exclusions list.
Define exclusions for behavior blocking-Comodo Help

Kind regards.

Hi,

This is to inform you that false-positiveSHA1:01f78aed4eba4a469a83a90eb65a7061ebf2e130 has been fixed.
You can update to AV database Version <19140> of Comodo Internet Security Version<7.0.317799.4142> and confirm it.

Best regards
Qiuhui.■■■■

Very cool, thanks. Impressively quick! I admit I did not expect it that fast.

Thank You so much!