HELP: Can't pass CPIL Leak Test

I’m not passing the CPIL leak test even with Defense + on. What changes need to be modified?

Hi Jack

Out of the box settings and…

Did this fail with your installationof the previous version? If so, did you uninstall-clean install this version, or did you upgrade from the previous one? I’m just wondering if you’ve inherited a bad “Allow” from the previous version.

Ewen :slight_smile:

I don’t remember if I even tested 2.4 with CPIL. I guessing I did but I’m really not sure. And yes I did uninstall my last version 1st and then installed 3.0

Hi all

Shot in the dark Jack, but what is or was your defence+ setting at the time you ran the test?

It was set on train with safe mode then I set it to paranoid to test it out again and it still failed.

i got the same failure using CPIL. CFP firewall set to train with safe mode, defense+ disabled:
1)CPIL ==> failed
2)PCflank==> failed
3)GRC ==> pass
4)surfer ==> failed
6)ghost 1.1 ==>failed
7)firehole==> ??? not sure, i think the connection was failed
9)wallbreaker ==> test 1: failed
test2 : failed
test3 : failed
test4 : failed

:frowning: what did i do wrong?! no defense+ no protection ?

You need defence+ ganda.

oh OK, then i don’t have no problem at all ;D . i thought my CFP doesn’t work well (:TNG) .

errr, what about these (attached) ? i failed (:SAD) defense+ & firewall on train with safe mode. the app open IE, and no alert at all. and i have the same issue with CPIL test 1. after i allow it (i don’t tick remember), the next time i use it, no alert from CFP.

V3 still remember the defense+ “allow” action. after rebooting, i got defense+ alert

[attachment deleted by admin]

Hi folks

quota>You need defence+ ganda.

@coolio10 CPIL is a firewall leaktest application, ganda should have passed surley even if D+ was disabled?

@ganda i passed the test as above but my setting for FW was train/safe/mode and D+ was clean pc mode.


Tried the test myself but could not even get it to work properly. D+ was off. I got it to work once but it gave some weird message for the text.

I have been a user of Comodo Firewall Professional for a while now, and was glad to see the excellent new features in version 3, and the new test utility available for download on Comodo’s website.

However, my installation of Comodo Firewall Pro failed the basic leak test. Naturally, I assumed it was my custom settings that caused it. So, i uninstalled Comodo Firewall, rebooted the computer, reinstalled it with default settings and rebooted again. When my computer was up and running again, i decided to run the test just to make sure (test number one on the CPIL test utility) and once again CFP failed.

Please can I have some help regarding the reason why this is happening, and how i can resolve the issue. Thanks.

If you need anymore information (system specs e.t.c) I will gladly provide them.


Maybe it was because you already had the test in your hard disc, so Defense+ considered it safe in clean PC mode. Try in D+ train with safe mode and erasing any allowing rule learned about the test by the clean PC mode.

Or it is signed by Comodo which is why defence+ trusts it…:smiley:

i think you pass the test coz you block the leaktest app when defense+alert show up, not the firewall (your attached screenshot). and i was to stupid that i allowed it coz i wanna see the Firewall alert (:TNG) .
but Japo told me, that we need to enable D+ in order to have a maximum protection & less pop up (like in V2),
i think, defense+ warned about something when it was trying to take control over an allowed app, for example :
IE is a trusted application
the leaktest app wants to take control over IE
then defense+ warns us about that suspicious behavior
then if we allow it, we basically give the app a ride,

am i right? (if i’m wrong, you can blame Japo ;D )
so defense+ is a must have. can’t activate them separately.
(but what if we chose to install only V3 BASIC firewall, maybe V2 is better than having V3 without defense+ ??? ).

and what about these test?, i got no warning when i used the app, and it opened IE telling me that firewall is leaked.

and is this a bug ??? :
after i allow it (i don’t tick remember), the next time i use it, no alert from CFP.
what if i have a trojan who wants to send some info out, the first time CFP warns me, i accidentally allow it, and then the second time, CFP doesn’t give any alert. we’re doomed :o

edit :
i’ve just tried dnstester.exe one more time, defense+ tell me that Explorer.exe try to execute dnstester.exe.i believe we have to allow it coz the test hasn’t begun yet. but i block it (i don’t tick remember) (but ofcourse, in reality, we cannot allow something that we don’t know). but the point is : [b]now i can’t use dnstester anymore. not a valid win32 app[b]???
V3 remember the action we’ve done even if we don’t tick remember.

Hi all

Ganda japo is correct in what he says, D+ is IMO a great feature and is certainly benifitial if the user enables it, many people will say that they don’t like it coupled with a FW, but the truth is that for me its staying.
But i still stand by my opinion that if we have D+ dissabled and we test the functionality of our FW with a leaktesting application , we SHOULD still pass!
Im sure someone else will come in if i am wrong here as V3 is new to us all here, but surley if we passsed leaktests in V2 and V3 is far more powerfull…what is happening!

PCflank leaktest…with D+

PCFlank leaktest D+ dissabled and FW set to Train with safe mode…Failed

I am at a loss here, will post back later and try the test again
novie :Beer

has somebody tried this leaktest using V2 ? (maybe defense+ function is similar to application monitor in V2). i didn’t care about such test before. but i remember in V2, after i do anything that needs internet connection, V2 app monitor will create an alert, just like defense+.

have you tried dnstester or wallbreaker?, you also will fail the test if you allow it in defense+ alert.
i only got firewall alert when i tried leaktest.exe, this app try to connect using port 80 (webbrowser port?),i think the firewall will respond to something who wants to connect directly like this kind of leaktest,
but if the app tries to access/hijack a granted app like IE or svchost,it will trigger defense+ alert. if we allow it, the firewall won’t do anything about it, coz basically the firewall only allows the granted apps (IE or svchost), not the leaktest app.
and this is a BIG problem (at least annoying) :

unless we reboot our comp.
i’ve accidentally blocked something, and i need to reboot to use it back >:(

Hi ganda, If you did not tick to remember, your answer would be valid for the rest of your session…you have to restart your pc for V3 to forget about it…now if you choose to remember your answer it will create a rule and even if you restart it would still remember it.

I think it was created this way to minimize the pop-ups, imagine a persistent program nagging you every minute…you would want to block it but just for this session…so would just choose to block it without remembering your answer and it would be blocked till you shutdown your pc…if comodo has done it any other way…you would have to block it every single time or choose to remember your answer.

As for the leaktest…I do believe that what we have in V2 is a partial HIPS implementation designed
to protect the firewall…in V3 we have a full pledge HIPS implementation. I guess users should install both…if you just install the firewall then it’s just a basic firewall…

ya, but if i don’t wanna see those pops up from that persistant program, then i will tick remember ??? why should i restart my comp, to “refresh” CFP memory.
i was too stupid that i accidentally blocked a safe app (:TNG) .