Help! BSOD on starting even in safe mode - ndis.sys CF v2.4 OS: W2KSP4

I have installed the current comodo 2.4 version onto Windows 2000 SP4 machine.
After installation the system was restarted.
Upon restart it BSOD related to ndis.sys and I cannot get it passed the blue screen.
Booting in ‘safe mode’ and ‘last known good configuration’ and even ‘Safe Mode with Command Prompt’ results in the same bsod.
I desperately require some help in starting the machine and getting rid of this cursed Comodo Firewall.
Can anyone please advise what options I have?


anybody. Please.

I don’t think it is Comodo causing this error, I believe it is a coincidence that it happened when you had Comodo.

Here is a link for a page about this problem.

And here is a link to a discussion some people were having that managed to solve the problem.

Hi, thanks for that.
The other factor which I omitted was that the w2k server is running fully virtualized in xen.
I ended up having to reinstall from scratch. This time however, I backed up the virtual system before installing comodo fw. Result was identical. Also tried Online Armor Personal Firewall V2 Free version. Again same result with ndis.sys read only error.
Very stange that I cannot even boot to command prompt when this problem occurs.
The IRQ assigned to the NIC is 11 and 11 is not assigned to any other device.
At this stage I have given up on trying to put a firewall on W2K SP4 on fully virtualised Xen system, but at least from a comodo perspective it is not restricted to only comodo fw.