Hedgewars process exits from memory when using CIS

The bug/issue

  1. What you did: Installed latest Comodo CIS and Hedgewars
  2. What actually happened or you actually saw: Hedgewars crashes as soon as you try to play a game.
  3. What you expected to happen or see: Hedgewars should not have crashed, and does not crash if CIS is not installed.
  4. How you tried to fix it & what happened: Uninstall CIS. Inserting it into game mode and disabling the entire thing does not fix the bug.
  5. If its an application compatibility problem have you tried the application fixes here?: [i]The problem was reported and considered invalid for Hedgewars here: Google Code Archive - Long-term storage for Google Code Project Hosting.
  6. Details & exact version of any application (execpt CIS) involved with download link: http://download.gna.org/hedgewars/hedgewars-win32.exe
  7. Whether you can make the problem happen again, and if so exact steps to make it happen:
    Install Hedgewars on any computer containing CIS, and try to join or host a multiplayer game.
  8. Any other information (eg your guess regarding the cause, with reasons):
    CIS is messing with “NULL pointer” and causing the game to crash.

Your set-up

  1. CIS version, AV database version & configuration used: 5.3x +
  2. a) Have you updated (without uninstall) from CIS 3 or 4:
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: Nope.
  3. a) Have you imported a config from a previous version of CIS:
    b) if so, have U tried a standard config (without losing settings - if not please do)?: Nope.
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): Nope, effects mutliple users as well.
  5. Defense+, Sandbox, Firewall & AV security levels: D+= Safe , Sandbox=Enabled , Firewall =Safe , AV = Disabled
  6. OS version, service pack, number of bits, UAC setting, & account type: Win7 x64 SP1
  7. Other security and utility software installed: N/A
  8. Virtual machine used (Please do NOT use Virtual box): N/A

Hopefully you’ll find that one of the fixes in this FAQ works, or someone else can help.

So I’m moving this to D+ help for the moment. If none of these fixes works, please ask any mod to move it back here.

Hope this is OK

Best wishes

Mouse

I completely disabled the sandbox, and tested all the options you had mentioned here:
https://forums.comodo.com/defense-sandbox-faq-cis/app-is-not-working-correctly-but-does-not-seem-to-be-sboxed-what-to-do-v5-t61684.0.html;msg434597#msg434597

But nothing seems to work, so I think it is still a bug. Thanks for the help though.

OK that’s fine will move back

Could you post a screenshot of your Active Process List, Defence PLus and Firewall logs please. Just after rebooting and starting Hedgewars if possible.

Best wishes

Mouse