hdd recognition [Solved]

i have a 1tb plug and play hdd that i made the mistake of not allowing comodo to install the first time i plugged it in and now i cannot get my pc to recognise it which has become a real hassle

could someone please tell me how i can make the necessary changes to get my pc to recognise the hdd

i am running windows xp… not to sure how to tell which version of comodo i have


Hello megamark and Welcome to Comodo Forums

To check what version of Comodo you have, you may go to
(if you have 4.x) CIS > Misc >About or (if you have 5.x) CIS > More > About

You can simply throw CIS into training mode and then try plugging in your External
*Right Click CIS icon > Defense+ > Training Mode

Did this solve your issue?


hi jake

thank you for your quick reply

i have the product number found in the misc>about section 3.14.147648

did you mean going into instillation mode and trying the drive, i have done that and still no recognition

3.1 is pretty old!

You can try going defense+ section (CIS > Defense+ Tab > Advanced > Computer Security Policy > Slide the bar down to Training Mode) Does this help?

i am there now but there in no training mode option

Aye Sorry about that (It’s been about a year or so since i last had that installed,

let me install it on my PC real quick , and i’ll get back to you…

another quick thought…completely remove cis and start again ??

ps sorry jake running late for work …i will be able to access your reply but wont be in front of my own pc, i can try your next idea when i get home and report back then


That will solve it, or just remove all policy’s that are applied

CIS > Defense+ > Advanced > Computer Security Policy > Delete all except the group’d policies

In Defense+:

-Common Tasks: check if you have relevant blocked or pending files.

-Advanced Tasks:
Try to gain some time, go to Defense+ settings, Monitoring parameters: uncheck the disk direct access item.
It now should work.

If not, go to strategy security, and check whatever rule has been enforced and keeps you accessing your removable disk.

I assume that the said disk has no installed os, if it does, a firewall netbios rule (or more exactly the lack of it) could deny the access.

If you are running the AV in 3.14, you will no longer be getting updated virus definitions. In order to get updates, you’ll need to upgrade your installation.

hi everyone

thank you all for your quick replies and suggestions re how to solve my hdd problem

i have upgraded my v of cis and was asked during the instillation if i wanted to allow the hdd ‘in’ and this time gave the appropriate answer and all is well

many thanks again


This thread will be closed on the basis the problem is solved!

Thanks All who helped