Having to close main GUI to re-activate the password protection. [M262] [V6]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic title, NOT here.

  • Can U reproduce the problem & if so how reliably?: Yes reliably.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
  1. Enable password protection.
  2. Close and re-open the GUI.
  3. Open a password protection function and enter password then select OK.
  4. Close the password protection function without closing the main GUI.
  5. Select a password protected function again, no password required.
  • If not obvious, what U expected to happen: I expected to need a password again when opening a password protected function without the need to close the main GUI to re-activate the password protection.
  • If a software compatibility problem have U tried the conflict FAQ?: N/A.
  • Any software except CIS/OS involved? If so - name, & exact version: No.
  • Any other information, eg your guess at the cause, how U tried to fix it etc: My guess is, it is a design fault.
    Closing the GUI of CIS completely is required to re-activate the password protection after using a password protected function.
    This could be trap as the main GUI does not need a password, so anyone leaving the main GUI open (even minimized) after closing a password protected function would expect the password protection to be re-activated without the need to close the GUI of CIS completely.
  • Always attach - Diagnostics file, Watch Activity process list, (dump if freeze/crash). If complex - CIS logs & config, screenshots, video, zipped program (not m’ware)
    [/ol]

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: V6.0.264710.2708, proactive.

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: CIS proactive defaults.
  • Have U made any other changes to the default config? (egs here.): No.
  • Have U updated (without uninstall) from a previous version of CIS: Yes, only from V6.0.260739.2674.
    [li]if so, have U tried a a clean reinstall - if not please do?: No but I will, only if necessary.
    [/li]- Have U imported a config from a previous version of CIS: No.
    [li]if so, have U tried a standard config - if not please do: N/A.
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, & VM used: Win 7, No SP, 32Bit, UAC off, Admin, No VM.
  • Other security/sandbox software a) currently installed b) installed since OS: a) None b) Previous versions of CIS.
    [/ol]

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

Mouse

Replicated on my machine.

This is the same behavior as v5 so idk if this is a bug or lack of functionality.

Bugs can persist ax versions :slight_smile:

I guess the user will see this as an ‘issue’ - ie a problem, at least

[Edit: ‘what is a bug’ and what is a wish list item is a thorny issue which I try to address: here.]

Not fixed in _2801.

Note: Steps A-3 also effects the widget until the main GUI is closed to re-activate the password protection.

Not fixed in _2813.

Tracker updated, thanks

Can you please check and see if this is fixed with the newest version (6.2.282872.2847)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Fixed in _2847.

Thank you.

I will move this to Resolved.