Have to un-install Comodo to connect.

I have installed the Comodo firewall to my comp.
I’m running Vista.
I lose my Broadband connection and get a box for ‘Dial-up’ Internet [Does not work anyway]
I’ve tried re-setting my internet. Reinstalling Comodo but in the end I have to un-install Comodo permanently to use the Web.
Can someone help -please? >:( >:( >:(

are you unable to open any applications that use the internet in any way? And can only open windows explorer windows? If this is the case then it sounds exactly like my problem from a few posts below yours. And i hope it is because then maybe they will realize that the problem was from there last update like i said and they maybe will start looking into it.

Welcome to the Forum, Rinoz.
Does your IE settings show it trying to use a proxy?
What are the settings in CIS? Go to Miscellaneous/Settings/Proxy. It should be getting its settings from IE.

Thanks for replying and showing interest.
With Comodo installed - I CANNOT get a connection to IE.
I get a DIAL up box that requires password etc etc. I am NOT on dial-up [of course]
No matter what I do - like going to Control Panel and creating a new Broadband connection - it always reverts to the above.
I HAVE TO UNISTALL COMODO to return to normal.
I was recommended to use Comodo and would very much like to - but it may be that I have no option than to leave it alone.
I’m hoping this Forum can help solve the problem

First let’s get your system back up and running so that it is usable again. Uninstall CIS and use a registry cleaner. Make sure everything is running as it should be.

Cleaned and cleared.

I have tried to set up Comodo Firewall up once more - but it still seems to block my connection and I still get a Dial-up box and no automatic connection to Broadband.

Even after it has been uninstalled, I feel there are ‘remnants’ of Comodo on my comp.

I also noted that the firewall was not working when it was on my task bar. [There was a X on the icon].

What other factors could created this? What about Vista’s firewall settings?

Oddly - this programme is working just great on my lap-top!

Windows Firewall must be disabled (manually from Security Center). You can also disable the Windows Firewall from Services.

Are you using Vista as admin or limited user? Open CIS → Summary and look at System Status. In case it is in error go to Miscellaneous and run Diagnostics. Let us know what it says and if it manages to correct the problem or not.

When you are limited user try uninstalling CIS and installing it as admin. To do so click right on the installer → Run as admin. Or when it doesn’t show up like that click right → Properties → Compatibility → set it to run as admin.

Thanks so much for your continuing help.
I seem to be getting somewhere.
I have managed to install Comodo now - but in order to connect to the Internet and send emails - I have to DISABLE the application. [Not uninstall]
I am a bit confused now as Comodo shows System Status active and running although disabled.
I am sending a combined screenshot for comment.
Am I protected at all?
Also - how to you reverse choices made under ‘My Protected Files’ & ‘My Blocked Files’ ?


Can you tell me what your rules are for svchost.exe and system? You can find them here: Firewall → Advanced → Network Security Policy → Application Rules.

Can you also post a screenshot of the Global Rules (they are under Network Security Policy also).