Hardware-assisted virtualization blocked.

A. THE BUG/ISSUE (Varies from issue to issue)
Following install of CIS, multiple applications relying on hardware-assisted virtualization fail.

Can you reproduce the problem & if so how reliably?
Yes; very reliably.

If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Following installation of CIS 8, application Core-Temp failed.
2: Following installation of CIS 8, application Windows Virtual PC (XP Mode) failed.
3: Following installation of CIS 8, MS HAV Detection Tool (havdetectiontool.exe) comes back with dialog stating “Hardware-assisted virtualization is not enabled on this computer”

One or two sentences explaining what actually happened:
The applications listed (above, #1 and #2) worked as expected prior to installation of CIS 8.

One or two sentences explaining what you expected to happen:
I expected them to function (as prior to installation of CIS 8.

If a software compatibility problem have you tried the advice to make programs work with CIS?:
I experienced no such problem when running CIS 7.x.

Any software except CIS/OS involved? If so - name, & exact version:

Any other information, eg your guess at the cause, how you tried to fix it etc:
I uninstalled CIS 8 and both applications worked as expected. I also ran the MS HAV Detection Tool and it came back with a dialog stating something to the effect that hardware-assisted virtualization was functional (I did not capture the exact message wording.

Exact CIS version & configuration:

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
D+/HIPS, Firewall and AV. No Autosandbox/BBlocker.

Have you made any other changes to the default config? (egs here.):
Extensive. Attached configuration file (named cajemobile3.zip).

Have you updated (without uninstall) from CIS 5 or CIS6?:

Have you imported a config from a previous version of CIS:
Yes. However, have mainted a customized config file for several years. Have always: (1) installed new version of CIS; (2) imported my customized config; (3) exported resulting config; (4) performed a diff between my customized config and the newly exported config and have made adjustments to my customized config as appropriate; (5) have gone back to step (2) and reiterated until satisfied with customized config.

if so, have you tried a standard config - if not please do:
Yes. Have switched between utilizing my custom config and the initially utilized Comodo config. No difference found.

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Running Windows 7 Ultimate, SP1; current on all MS updates.
Running an admistrator level account.
UAC turned off.

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=Spybot Search & Destroy (ver. 1.62.). No others. b=None. Clean install of OS 3 months ago (not and OEM disk).

[attachment deleted by admin]

I’m personally noticing a trend here between those using Virtualization Technology enabled in BIOS and CIS’s Enhanced Protected Mode causing a myriad of problems.

It has been a very long time since I’ve tinkered with virtual machines, but I have to ask two things. 1) Is it possible for you to run those hardware-assisted virtualization programs WITHOUT said function enabled in BIOS? and 2) Would Enhanced Protected Mode be one of those settings within your special configurations?

COMODO Internet Security, at least from the look of things, should NOT be interfering with virtualization unless Enhanced Protected Mode is enabled, as that particular component does use a bit of it. On top of which, there is even a warning that hardware virtualization programs may run into issues before you even enabled Enhanced Protected Mode. Perhaps you are not seeing such a warning, as you are importing previous configs.

Also, you did not specify 32/64-bit in your report, which may be of considerable value to the moderators/developers helping you with the issue. Enhanced Protected Mode, since it’s inception, has felt to me as a 64-bit necessary function, and not necessarily 32-bit, though that may have changed as of late or I simply don’t understand how the function works to the fullest developer intentions.

It may be that this is another manifestation of this bug? https://forums.comodo.com/format-verified-issue-reports-cis/enhanced-protection-mode-causes-hwmonitor-speccy-to-malfunction-m1370-t108241.0.html

Not sure if it’s a duplicate. It would need more in-depth analysis of how the applications actually work.
I would link the reports in the tracker anyway.


Thaumasurge, thank you for your comments/observations.

First, my OS is Windows 7 Ultimate 64. My CIS is also 64 bit.

You got me thinking as regards your initial questions: 1) I do have to utilize hardware-assisted virtualization. Windows Virtual PC (under my environment) requires it. 2) Aha! I haven’t thought much about this setting since it was first introduced. Especially since, as you noted, I’m always simply importing a customized configuration file. I have now noted this and am going to modify my approach somewhat. In any case, I turned this switch off and this issue disappeared. I am satisfied with the result and hope the information may give the development team some useful insights.

Again, thank you.

GlennB, please link the mentioned applications.
Also, please attach a system summary. (run > msinfo32 > save)

Thank you.

qmarius, not sure how to link the mentioned applications… Post some info on this (an example?) and I will gladly do so.

Ran the system information report and have attached.

[attachment deleted by admin]


ApplicationName - Link : http://example.com

As there has been no response, I will move this report to “Resolved/Outdated Issues” section.

Thank you.