Hamachi - can be pinged but can't see lobbies when firewall is up

Hi there, I am trying to use Hamachi to allow me to play a multiplayer game online with my friends. I tried searching threads for others having hamachi problems but did not find any solutions. I have set the Hamachi program as a trusted application as well as the game I am using (demigod). I have also added the Hamachi network ( to trusted zones. Hamachi responds to ping requests from others, however when I go into the game itself I cannot see the lobby’s they have created if the firewall is active. If I disable comodo firewall I do see the lobbies. I am unsure as to why the firewall allows the ping response but doesn’t allow me to see the lobby.

All I can think of is that there is a conflicting rule somewhere. Only way I can see to easily resolve this is remove all of comodo’s current rules (is there a simple way to do this?) and then start from the beginning again.

Any help would be appreciated, thanks in advance - Boffinboy

HI Boffin,

Please try putting the Defense+ element in “Training Mode” and clear your “my pending Files list”. Next run the game for a minute or two so CPF can learn the program.
Exit the game and then put back into “Clean PC Mode”

You may need to reboot but run the game again and see if it fixes it.


Hi Eric, thanks for your help. Defense+ is totally disabled as there is a conflict between that and demigod which prevents demigod from starting. The problem is only with the firewall aspect of Comodo as it is resolved when I turn the firewall off. I tried using the firewall in training mode but it made no difference, does it need to remain in training mode for long?

It should only take a minute so that CPF learns your application. I’m at work at moment but search the forums for info on getting CPF to work with online gaming. That might help further… Right, I’m off back to work… :-X

Thanks Eric, I will try when I get home too :wink: The guides i seem to find seem to be for the old versions of comodo firewall, not the new one in comodo internet security. I’ll have a search anyway :slight_smile:

Hi BB,

Have you tried the Hamachi Network trusted zone via the “Stealth Ports Wizard”?

Stealth Ports Wizard->Next->I would like to trust an existing my network zone->Choose the zone from the drop-down menu->click Finish->you should get the message your firewall has been configured accordingly.

There will now be 2 rules in Firewall/Advanced/Network Security Policy–>Application rules(under system)
Plus 2 in Global rules


Hi Matt, I haven’t used the wizard but have manually made two rules under global allowing IP out to all in Hamachi network and IP in from anything within Hamachi network. Likewise I have set up two to the same effect under system. Would using the wizard set up anything different to this?

Shouldnt do,it may be worth removing the made rules and trying it though. Is there anything coming up in the logs? If not try unchecking Attack Detection Settings/Miscellaneous/Block Fragmented IP datagrams(if this doesnt do anything be sure to re check it)

That’s the confusing thing, nothing appears in the logs. Whichever rule is blocking it (and not blocking the pings) is obviously not set to log. I will try you suggestion about the blocking fragmented ip datagrams!