Half-Life 2

This is an old bug. When Defense+ is enabled, after starting HL2 the system hangs and stops responding. Adding hl2.exe to trusted list didn’t help.

Try making all the .exe files in the Half Life folders Trusted.

Or put D+ and the Firewall to training mode before staring hl2. CIS will now learn the rules without notifying you. Then after a couple of minutes stop the game and put D+ and firewall back to their regular settings.

I have had this problem the way to solve is just like Eric said put D+ into training mode start up HL2. Play for a little then switch it back and HL2 won’t freeze anymore. This bug happens because D+ is asking your permission to as whether HL2 can connect to the Internet and if it can install a DLL but since you’re in full screen you can’t see the pop up, so HL2 Crashes

Exactly right, the same thing happens with all the Valve games and running them the first time in training mode does eliminate the problem.

this happens with every game in full-screen mode. Could be Firewall or D+ settings.

Thanks man and Mr. Henky your right about that too

This is Bullpoo !!!

Since v3.8 if i want to play a game i have turn off D+ or switch to Training Mode.

Before v3.8 i could play every game without any problem with D+ in Safe Mode.
I dont understand how can’t you fix this freaking D+ bug. We can’t go back to desktop to see the pop up
because of the black screen (guess wath before v3.8 you could go to the desktop to se the pop up)
You can screew it but you can’t fix it great job :-TD.

Serious Sam 2 is affected as well.

This sounds like the impact of an anti-cheat component rather than Half-Life 2 itself to me. I play CS:S and DoD:S (both Half-Life 2), as does my son, without any issues under CIS that I know of. I did use Training Mode to teach HL2 to CIS myself, but my son did not (he just trusted all steam components).

I guess this could be impacted by the Defense+ Mode… Safe Mode is used in both cases here.

Will this ever get fixed? It’s extremely annoying. I’m thinking of uninstalling Comodo just because of this.

Comodo is working ■■■■■■■ version 4 which will bring among other things a new GUI and usability enhancements. May be a game mode feature will be there. Current estimations assume a beta version late December.

Is it so hard to fix this bug, why do we have to wait v4, for this bug to be fixed.
How could this work so great in v3.5 . I used Comodo for few months before the v3.8, and i had never any problems with games /full screen app with D+ in safe mode.