Had to remove the CFP

I wasn’t able to make the firewall work to the simple point of just getting out from my notebook to the network for a couple of days. I had the global rule set according to what many here recommended and I let default options in the program stay as they are. Yet, the exclamation mark in a yellow triangle in the system tray stayed like it was a hardware problem…

After I removed the CFP everything is working. I removed ZoneAlarm in order to go to Comodo, and I don’t want to install ZoneAlarm again. I’m using XP Pro SP2 firewall right now until I’ll learn more about CFP. I hope to find a SHORT and to the point guide that will allow me to connect without being too technical.

So far I found a lot of technical exchange of info and nothing for the new people.

Can you be more specific? What yellow triangle in the system try? What did it say? What kind of troubles are you having?

Hi Devek

Sorry you’ve had problems. Don’t worry I’m not going to get technical on you… well, I’ll do my best anyway. :slight_smile: But, I just have one question really…

The exclamation mark in the yellow triangle on your system tray. Was that the only problem or was there something else? I ask… since, that was an alert from the Windows Security Center (WSC) and, for the most part, you can almost certainly ignore it… it isn’t a problem as such, it’s usually more like WSC not detecting CFP properly & complaining about it (which is really only a problem for WSC, not the user or CFP).

edit: Sorry, Vettetech the BB didn’t warn me you had posted.

Thats ok kail. If Windows didn’t detect Comodo running then maybe there is an install problem cause when I open up the security center on both my pc’s it shows Comodo Firewall Active.

I believe he was one of the ones who was unable to get an IP address after installing CFP3. Exclamation point is in the network connection icon for limited connectivity. Not much to offer in the way of simple solutions, since the thread https://forums.comodo.com/bug_reports/301722lots_of_network_connection_problems_merged_topic-t19817.0.html has a lot of technical information but often no solution. Suggested trying fixed IP, but may have been too technical. Maybe we’ll get lucky on this bug report too. :slight_smile:

OK, I’ve now read the other posts (well… not all, mainly Devek’s). The warning is on the Network connectivity, not WSC. Thanks sded.

Devek: Do you plug your laptop into more than one Network? Say, one at home & one at the office?

sded wrote in an older post: I use a wired fixed IP instead at home

I decided to try the same. I placed the IP address of the NIC into the properties of the Network Connections (wired). The Exclamation mark and the yellow triangle disappear from the Network icon in the system tray and its properties now say Connected.

There is nothing else! No actual access to any network nor the internet. The notebook is connected directly to the router (D-Link). The network icon usually will blink in light blue when there’s any activity, but it is now dark blue, as in ‘no activity’. The static IP was a step forward.

Now what else can I check?

Attached is the setting screen. The Global Rules screen is empty. Not one entry.

[attachment deleted by admin]

Firstly, if I get too technical on something, just say & I’ll try to explain it another way.

OK… whilst changing your NICs IP address from a dynamic IP (obtained by something called DHCP) to a static IP address would resolve the Network systray warning, unfortunately it might mess up CFPs current idea of what your LAN (Local Area Network) looked like (in terms of individual bits of kit’s IP address). However, since DHCP wasn’t working (ie. obtaining a dynamic IP address) & the fact that you have no Global Rules, then I doubt that it was set-up correctly anyway.

Question first: What does your LAN (Local Area Network) actually consist of? I know there is, at least, 1 Notebook & 1 router. Is there anything else?

Thanks for the flexibility. I have the common sense, so I can follow :slight_smile:

I understand the concern with the static IP address. At this point I’m just trying to see what works.

My home LAN is: One desktop (running ZoneAlarm. I use it to type this) one notebook that is connected to the router together with the desktop using D-Link DI-624. I know, it is outdated, I just checked. Both above computers are connected directly to the router with cables. There’s a third notebook that is connected to the router via wireless connection. That notebook is running ZoneAlarm and has no problem connecting, just like the desktop I use to type this post.

The router is connected to the newest Comcast cable/voice modem. Connection speed is DL 20+ MPS, UL 1.7MB.

My goal is to remove ZoneAlam completely from all computers as soon as I find something better that works… literally.
The notebook that’s connected to the router via cable was selected as the test computer for a new firewall. So far, in order to use the computer I have to uninstall CFP. Exiting the software does not enable connection to the network. It has to be uninstalled.


Right, rather than uninstall CFP to get the Notebook working… right click CFPs systray icon - hover over the “Firewall Security Level” & select disabled. No more firewall, disabled. Terminating CFPs front-end will actually do nothing, other than to stop CFP talking to you. BUT, I’m not asking you to do that… that’s just for information.

Right what the problem is… Your router has an IP address (defined via Web front-end, and probably still accessible via your desktop). CFP didn’t know about the router’s IP address (or the router) and that’s probably why the dynamic IP address assignment (DHCP) failed… CFP blocked it. Usually on install, or when its first used, CFP detects NICs & asks you if you want to share that network. Answering “Yes” would have set-up the appropriate rules to allow proper LAN access (to the desktop & the router). I’m not 100% sure if the dynamic IP assignment (DHCP) would have worked or not, but I suspect it would have. If not, a couple of extra rules would have sorted that out as well.

Sorry, one more question before we can sort you out… I note from images you posted a reference to LAN#1 in the rules. So, something did happen on, the above mentioned, Network detection, but it obviously didn’t go well. So, I need a screen shot of your My Network Zones (Firewall section) as I need to know what is currently in there. Remember to make the screen bigger (works like a normal Windows… erm… window) so that all the details are visible. Thanks.

OK, I note you’ve gone off-line (maybe to try somethings based I want I’ve already said or grab the screen shot)… But, I need to get some Zzzz’s… so late here, it’s now early. :wink:

I’ve already posted enough, I believe, to let other people know what I’m talking about… so, you might get extra help from others. Failing that, if you cannot wait, here’s somethings you can try yourself & some additional information…

a) Your routers IP address (by default) is probably:
b) Your routers web control page should have something called “DHCP Reservation”. This specifies the range of IP addresses that the router will dispense (to fit with (a) usually, -
c) If (b) is not there, D-Link usually have a support web page, specifically designed for your router type that helps you set-up stuff like this & export it to your router.

  1. Set your NICs IP address back to dynamic.
  2. As I suspect you’re used to this by now: Uninstall & reinstall CFP.
  3. When CFP detects the LAN, say “Yes” and call it something sensible (eg. LAN).
    3.1 Don’t worry if DHCP is not working at this point.
  4. Check CFPs My Network Zones (Firewall) & ensure that the newly created LAN fits with (a) & (b). So, something like… - If not, change it.

DHCP should be working now & your desktop should be visible from your notebook.

If not, and you can’t wait, somebody will help you set-up what you need to get DHCP working or… as a work-around… set your NICs IP back to a static IP. The problem with this is that there is a risk that the router might issue the desktop with the same IP at some point & cause a conflict. Changing the desktop to a static IP as well & turning DHCP off on the router would resolve that.

I hope that helps… as I did type it fairly fast.

Hang on… you’re back on-line again. So, I’m still here.

Yes, I’m online and will start your lesson.

First, let me just tell you that Disabling Comodo (right mouse button click in the system tray) didn’t allow the renewing of the IP address in the NIC.

I will now follow your instructions.

Will update as soon as I’m done with it.

Did you disable D+ or the firewall?

Don’t worry Vettetech. It wouldn’t have worked anyway… I strongly suspect that CFP is not currently set-up correctly with the router & LAN in mind (Network Zones)… no Global Rules is a give-away (see above). If you know what needs to be done (maybe some DHCP port opening, if required), would you mind taking over?

This is all you. I never had to go through this. Its odd but all I have ever done was install Comodo and it works. Sorry but some of this is beyond me. Same with my connection. I never had to play with my NIC settings or DHCP. The only thing I ever did was install OpenDNS.

OK, no problem. I’m going for a tea then. :slight_smile:

  1. Set your NICs IP address back to dynamic.
  2. As I suspect you’re used to this by now: Uninstall & reinstall CFP.
  3. When CFP detects the LAN, say “Yes” and call it something sensible (eg. LAN).
    3.1 Don’t worry if DHCP is not working at this point.
  4. Check CFPs My Network Zones (Firewall) & ensure that the newly created LAN fits with (a) & (b). So, something like… - If not, change it.

  1. Done
  2. :slight_smile: Yes, done.
  3. Done (like I did before. It detected the NIC in the notebook
  4. The LAN is there (169…), but there is no range of the router’s 192… I added that as a new network (see image)

No access to the network yet (the exclamation mark and the yellow triangle are there on the network connection icon in the system tray)

Reboot (by choice, sisnce nothing has changed on the screen)

… same no connection. I’m a bit concern about the 169… IP address. I guess it is the NIC. There is nothing else. The WiFi is disables with a switch. It can’t be connected to anything else.

[attachment deleted by admin]

Any Global Rules? If so, screen shot please.

Did you create those Network Zones or did CFPs install?

I suspect that when CFP first detected all the bits (router & LAN)… the router DHCP wasn’t working. So, as you said, it used your NICs default IP (the 169 IP) & this divorced it from the real LAN (router, 192). Changing the LAN to what Router says & deleting the Router is probably the way to go. But, it’s best if I can see the Global Rules & Network Security Policy first to be sure. Thanks.


I’m handing you over to Ewen (panic). He should be able to help you finish this off. :slight_smile: