GuildFTPd not working with Comodo

My Kaspersky license expires today, so I installed Comodo. I use GuildFTPd for LAN use only; I don’t want outside connections.

When I connected from my other Win2000 system with Filezilla, the directory lists were always blank. I tried going to ftp.exe and logged in ok. If I typed “dir” from /, that was ok. But if I tried something like “dir irda*” it would wait forever. In Filezilla, using passive mode did not help. Everything works fine if I set Security Level to Allow All, but I shouldn’t have to do this. My LAN IPs are set up as a trusted zone.

Having ftp for LAN use only simplies things considerably. There’s no router port forwarding to get in the way.

Have you checked the CFP logs (Activity → Logs) to see what might be there?

FTP uses several ports, and CFP needs to allow those ports. The base FTP ports are 21, 20, and several high ports that are part of your FTP server configuration. These same ports need to be allowed inbound by your CFP rules. That will let the LAN clients make passive FTP transfers, working thru their own firewall configurations.