GUI window is shown at Windows startup [Merged Threads]

as on topic :

on windows xp sturtup I always get the main comodo 3 windows opened

i’d like to stop this and anly see the tray icon I don’t want to close each time windows starts up that main page of comodo3 please tell how I can resolve it. No option found for this


By default it should be hidden in the background upon startup. Seems like your CFP registry entry might have been modified during installation somehow, but it should be:

Autorun entry from Registry:

Registry String Value:
COMODO Firewall Pro = “C:\Program Files\COMODO\Firewall\cfp.exe” -s

thanks for replay but the key in the registry is the same you wrote .

So no solution for now please tell me some more to solve this very noisy problem

No idea. Maybe a reinstall and this make sure you’re offline with other software disabled.

alreadxy tried it but un-install and re-install didn’t work … i’m so disappointed.

There will be some “switch” settings in the software that causes a popup of the main window…

Not sure if this’ll work but you could try changing “-s” to “/background” or “-minimize” and see if it solves the problem.


so sorry … did’nt work… any other ??? thanks

ps. i’ve switched back to 2.4 version …

You switched to an older version just because the GUI loads up every boot up? 88). There are users in the forum who experience the opposite: they want the GUI to load up but it doesn’t lol

Yes I went back to 2.4 : to me this problem was really noisy and sounds like not fully developed or that is still a beta unstable and for such a simple thing like this not working… iI’ve got a bad impression. 88)

Hope to install version 3 when this (and other)issues are solved … Thanks for a free product like this anyway. (:CLP)


After using Comodo Firewall (version unknown) for some months without any problems, I’ve had to reinstall some software including Comodo Firewall Pro (V3). I now find that each time I bootup, the Comodo main window is open and I have to close it down; not a major problem but one I find a nuisance. Please how can I stop this behaviour?


EDIT: adric thanks, I didn’t know about same advice and thread.

i’ve seen a report about this problem here.


Has anybody tried the simplest approach? Right click the shortcut and select “properties” and “run minimized”? Throw in “run as administrator” if using Vista.

Thanks goodbrazer for the quick reply.

I’ve tried that and have a screen image but am unable to see how to attach it in this forum. Anyway I don’t have the line you illustrated.

Under : C:\Documents and Settings\All Users.WINDOWS\Start Menu\Programs\Startup I have :
Firewall.lnk COMODO Firewall Pro COMODO c:\program files\comodo\firewall\cpf.exe

which of course only takes me to the folder.

I have nothing to do with Comodo under HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

Any suggestions?

Hi jeemo

You can edit the registry entry yourself by following goodbrazer’s link. Make sure you take out all the entries in documents and settings??\programs\startup or you will continue to have the same problem.


That’s even better.

In this case:

Instead try to leave shortcut and do nothing with registry entries.
Just in case: make sure that option “automatically start with windows” is unchecked in CFP’s settings.
Reboot, make sure there is only one icon of CFP on taskbar. Then open GUI: there must be green checkmark “all systems are active and running”.

To all who offered help, thankyou.

I tried editing the registry but of no use. I finally uninstalled the program, removed all file references to Comodo Firewall (but not the Verification Engine) and then deleted all registry references to Comodo Firewall (again not the Verification Engine) and reinstalled with success.

I had another look in the registry and this is the data entry inserted by the new installation in HKLM\Software\Microsoft\Windows\CurrentVersion\Run

C:\Program Files\Comodo\Firewall\CPF.exe" /background

Clearly “/background” is the required solution

Thanks again

I beg to differ. My reg entry has -s and I have not yet encountered the problem you describe. What I don’t understand is why a new install would change this setting. I always do clean installs and as you can see, I have something different, CFP is getting flakier by the day. :slight_smile:

Did you install 276?


I’m having this same problem with the last three subversions. The exact same thing happens with CMF also. “-s”, “/background” and “minimize” make no difference.

I suspect the startup process for these are being interrupted somehow by another startup process.
Sometime in the recent past CFP actually would hide itself on startup but the addition of some program or service seems to have changed that. I’ve yet to track down which one though.

Perhaps this solution is known by now, but just in case: using the -h switch prevents the window at startup. What I don’t know is the function of the -s switch, so I can’t say whether or not it needs to be retained. I have only -h, which seems to be a replacement for the previous “background” keyword.