GUI redraw issues (3.0.14.276 x32)

Hi,

Since I update to 3.0.14.276, whenever CPF is opened on my desktop (GUI), it takes an enormous amount of CPU and it draws everything really slowly. First time, I did a diagnostic that said that it found issues and fixed them. I restarted the machine to be safe, but the problem persists.

It only happens when CPF is in focus, not when some other program is in front, or if CPF is iconed.

Anyone else?

Thanks.

Cyril.

Edit: I didn’t make clear that since it uses as much CPU as possible, it also makes the GUI almost unusable as everything one does takes a long time to redraw. Something in the display code has changed between the previous and this version, and now, it’s definitively buggy, for me and others apparently. Curiously, it doesn’t seem to be a problem for everyone…

Have you changed something to do with DirectX, D3D, etc? that could be a potential problem.

I had this issue for ages, right from beta through 273. With 276 the issue has gone away, the GUI works as it should.

I was just about to type a post about this issue until I saw that it was already done for me. Since installing the final version of CFP 3 I’ve had the same redraw issues as well. Also with this latest version it is no different, in fact it’s actually worse.

*Running it on XP SP2 x32

“Glad” to see that it’s not just on my machine, that would have made it more difficult to find. I just wanted to add that the previous version 3.0.13 worked perfectly fine and has been a problem just with this new update.

Also: XP, SP2 x32, 2.2 Ghz AMD Athlon XP 2700+, 2048 MB RAM, plenty of HD space and Radeon X800 GTO.

Same here! Didn’t have the problem with 3.0.13. Came after uninstalling/reinstalling the latest (3.0.14) version.

WinXPSP2, including all updates. Radeon X700, AMD64 3000+, nForce4, 2GB RAM.

Is there a possibility to get rid of the Comodo skin and use the windows default skin? Might solve this problems ad hoc (and beside that I would love Comodo even more because finally ALL apps I use have the same skin - the “skin” topic was one reason for me to forsake e.g. Trillian and switch to Miranda.)

It would be nice if there was an option to choose ‘System Skins’ These Vista lookalikes are terrible. Maybe you should add it to the wish list…

i personally would like an option to turn off the skinning and revert to plain windows 9x theme - it could be easily skinable by 3rd party software like WindowBlinds…

I too have the same problem after uninstalling ver 2 and installing 3.0.14.276, the GUI would refresh really slow and the CPU would show 100% required to redraw. Any ideas to fix this?

can’t find the wishlist any longer?!
however, here we go:

  1. option to turn off skinning

  2. name resolution of IPs - i’m missing that feature as well - or did i just miss it? and i REALLY miss it!

  3. DIFFERENT icons for different protection states - i can’t distinguish between NO D+ and paranoid mode when looking at the systray icon - thats weird. we have the option to animate traffic (pretty useless from a security point of view, though i have to admit i’ve turned this option on :SMLR ) but we are missing that option!? even different colors of the shield would be great: green = firewall allow all, red = block all, white = custom policy mode. maybe add a small “overlay icon” to represent the settings, too (if that doesn’t make the icon too crowded: – = very low, - = low, * = medium, ** = high, *** = very high. and/or something similar for D+ (or some kind of number rating, e.g. 0 = everything turned off, 1 = firewall allow all, 2 = custom,…)

Question: why does comodo store the settings in the registry? wouldn’t a “plain file” be easier (reimporting, exchanging the settings)? whats the benefit of storing it in the reg? more secure? maybe someone could explain that.

regards

The registry is more secure.

I was experiencing some GUI redraw issues with 3.0.14.276 that i wasn’t getting or rarely with 3.0.14.273. I ran AusLogics Registry Defrag a really ■■■■ good registry optimizer freeware proggy,

since then everything runs faster and the GUI redraws faster and smoother.

something you might want to give a go and see if it does the same for you :wink:

I keep my C: drive defragged daily. Thanks for the advice, but in my case, the change is so radical that something definitively changed in the display code (DirectX, D3D?). Now, it’s almost unusable while in focus, meaning that configuring anything takes forever and is a major pain.

Definitively a bug.

I had the same slow GUI (annoyingly slow) with 3.0.14.276, went back to 3.0.13.268 and the GUI is fast again. It must be a bug in 3.0.14.276…

32 bits WinXP-home with SP2 and all updates, Radeon 9800pro, Pentium 4, 3GHz, 1.5GB RAM.

First of all thanks for the development team that solved a lot of annoying troubles (mainly the cfpres.dll), as some users here, recently had the redrawing GUI issue, in fact the GUI sometimes loads slowly but it does.

Second : I’m experience a PHP script trouble with the forums when I log in, further details here’s is the link

https://forums.comodo.com/comodo_website_issues_for_submitting_website_problems_only/php_script_language_error_added_a_picture-t17450.0.html

Just to inform I also have these redraw issues myself with .276. This didn’t happen to me with the old version.

It kinds of feels like a priority issue, like CPF is idling or has lowest priority when trying to draw the GUI, basically letting every other application finishing whatever they’re doing beforehand. Just a thought.

(V) (B) (R)

Maybe a workaround may work, don’t use the desktop icon, use the tray icon by the meanwhile, that’s is the mother of all the issues

The slow drawing was so annoying I went back to the previous version so I cannot test it at the moment. But I do know I never used the desktop icon, I always delete it after install. I noticed the slow drawing issue when I used the tray icon. I’m afraid this workaround will not help…

Half-Dead GUI - there is Comodo 1st answer; 2nd answer: probably GUI problem - incompatibility issue with Avast AV. Sounds unbelievable.

(:CLP) Avast doesn’t interfere, BUT, someone found out that ULTRAMON 2.7.1 (a dual monitor utility) was indeed the culprit. I use Ultramon myself and the moment I closed it down, Comodo was working again.

Well, Comodo, here you go: Ultramon incompatibility issue. At least, that one’s been confirmed.

I haven’t tried Ultramon 3.0 beta yet.