GUI does not respect regional date / time settings of operating system

The date and time format used in the GUI to show when the virus database was last updated is in US format regardless of the correct regional settings to be used as set in the Windows OS.

e.g. (for my computer using UK settings)
Currently shows as
Thursday, July 09, 2009 1:16:45 PM

but should show as
09 July 2009 13:16:45

I think you should take a look at the GMT main site. I’m from the UK and I’ve always used the format in your first example.

Perhaps you have your regional settings as US format?

As they say a picture paints a thousand words, see the attached for the Windows settings for UK and US formats.

Mine is set to UK and therefore the dates and times in the GUI should match the UK.jpg formats.

[attachment deleted by admin]

maybe I missed your point. As I said, I have always used, for want of a better description, the American date format.

If you look at the GMT website you will find:

[attachment deleted by admin]

Hi Toggie,

Sorry, perhaps I should have been clearer. I am not saying one format is right and another wrong, simply that the GUI should obey the OS regional settings. In my case, the long date format is “dd mmmm yyyy” and the time format is “HH:mm:ss”.

Interestingly though, the format in your screen shot is at least still showing the date using a UK format and not the US one used in the CIS GUI (UK = day number before month, US = Day number after month).

Might this help?

Unzip to …\COMODO\COMODO Internet Security\Translations and select “Language → English (United States 24)” in settings and reboot CIS.

[attachment deleted by admin]

So that’s the reason the language is described as Default - English (United States)

[attachment deleted by admin]

I did some sligthly changes in the .template-files and rename (copy) them and was to lazy to change description inside, I only added 24 in title so we know that’s 24-hour (UK or eg. swedish) format and not 12 ;D

Though it looks that setting Langid to 2057 (United Kingdom) don’t affect the date format.

<resource CompactMode="1" Language="English (United Kingdom)" LANGID="2057" RTL="0">

It looks like CIS use a custom (comma separated) time format string and change it accordingly to some Langid.

As 1053 (swedish) changes the formatting whereas apparently 2057 doesn’t, it looks like additional detection should be added to provide a custom comma separated format for 2057 (GBR)

The global long/short date/time formats are not used whereas changing the corresponding langid regional settings will also change the date display format in applications (regional setting are used also to customize the short/long date/time formats for a Language. Eg short format could be edited as dd/mm/yy or yy/mm/dd or dd/mm/yyyy and so on)

Thanks for the information Thunderbear, these files fix the time format, but unfortunately not the date issue as Endymion has stated.

At least it has given me a couple of ideas and I will go through the language files to see if I can find a way to get both the date and time to appear as I would prefer.

Your’e welcome.
Sorry for that, but it might depends on that my XP is swedish and therefore it shows as it should for me with date format (no, I don’t want swedish language but I want time and date in right order).
Good luck.