Guard64.dll Interfering With Various Windows Apps on Win 10 CU + KB4022716

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Can be reproduced reliably.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
While using CCleaner I noticed that it was cleaning out memory dumps. After the KB4022716 Windows Update I did a clean install of Comodo Firewall and set to proactive security, and noticed that my login speed was slower than usual. Checking the dumps with Visual Studio shows that guard64.dll is the culprit. I noticed that sometimes, apps like the Photos app on Win 10 doesn’t work properly.
One or two sentences explaining what actually happened:
Slower login time after KB4022716. If uninstall Comodo Firewall, then login time is normal. Before the update the login time was much faster with Comodo Firewall installed.
One or two sentences explaining what you expected to happen:
Normal login time, no memory dumps.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Not applicable.
Any software except CIS/OS involved? If so - name, & exact version:
Not that I know of.
Any other information, eg your guess at the cause, how you tried to fix it etc:
Cause is possibly the update causing conflict with proactive configuration, however dumps still appear with default firewall configuration.

Exact CIS version & configuration:
Comodo Firewall
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Firewall: Safe Mode
Auto-Containment: On
VirusScope: On
Website Filtering: Off
Have you made any other changes to the default config? (egs here.):
Proactive Security → Turn Website Filtering and HIPS off. Make VirusScope only monitor contained applications. Firewall is configured to block requests automatically.
Have you updated (without uninstall) from CIS 5, 6 or 7?:
if so, have you tried a a a clean reinstall - if not please do?:
Not applicable.
Have you imported a config from a previous version of CIS?:
if so, have you tried a standard config - if not please do:
Not applicable.
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10 Creators Update 15063.447, UAC Max, Standard User Account, Real System.
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
No active security is installed. Windows Defender disabled by group policy.

C. ATTACH REQUIRED FILES (delete this section (section C) after attaching required files)
Always attach the diagnostics file (instructions on how to do this provided here) and the KillSwitch Process List (instructions on how to do that provided here) and put the resulting file in a zip file. Both should then be attached to your post.
Note that additional information may be requested by the processing Moderator.

also notice these errors in Event Viewer

It seems that this problem is caused by detecting shellcode injections → if I exclude an app which crashes then the app no longer produces the dump.

For now I will turn it off until issue is fixed.

EDIT: After further testing it seems problem still exists for me even with shellcode injections off.

I’m getting the same issues here, started on the 28th June. All the built in windows apps hang for 5-10 seconds before opening & the login screen is much slower now. Already tried clean install of latest comodo firewall. Only thing that fixes it so far is uninstalling KB4022716.

Confirmed here also.

I upgraded my Win 10 x64 system from build 10563.416 (or whatever the prior cumulative update was) to 447 via the KB4022716.
Now I find that as soon as I login after bootup, explorer doesn’t start (and crashes if restarted from task manager), simply leaving me with a black screen, no task bar, icons, or explorer window. I’ve seen this on two PCs now.

Further investigation:
I went into safe mode, restored the PCs to prior to KB4022716 state, booted up. Which was fine (with CIS 10 installed). Uninstalled CIS 10. Reinstalled the KB update to build 15063.447. Still the PC was working fine (albeit without CIS). As soon as I re-installed CIS 10, and it did its initial bootup after the quick scan that occurs during installation, logging in, left me with a black desktop again.

So I’ve seen this on two Windows 10x64 systems with build 15063.447 and latest CIS 10. Looks like a reproducible bug - I thought I was the only one seeing it, but evidently not.

Just to clarify - I am using default “out of the box” CIS 10 settings.

Will be fixed soon according to Umesh:

Your issue is due to secure shopping which is already reported here.

Should be fixed as CIS RC is released to fix this issue.

is there any chance that the patch goes live ?