Group function not working in Protected COM [V6][M650]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.
The group function seems to not work in “Protected COM Interface”.

  • Can U reproduce the problem & if so how reliably?:
    Yes. It happens every time.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    The reproduce steps are :
    Steps of wrong result :
    Step 1. Create a group named “GroupA” in COM Interface,
    Step 2. Add “C:\WINDOWS\explorer.exe” into “GroupA”.
    Step 3. Add “GroupA” to “Protected COM Interface” (Allowed) of HashMyFiles’s Exclusions.
    Step 4. launch HashMyFiles.
    Step 5. Drag a file into the HashMyFiles window.
    Step 6. The alert window still popups (The rule does not work).
    Steps of correct result :
    Step 1. Add “C:\WINDOWS\explorer.exe” to “Protected COM Interface” (Allowed) of HashMyFiles’s Exclusions.
    Step 2. launch HashMyFiles.
    Step 3. Drag a file into the HashMyFiles window.
    Step 4. The alert window does not popups anymore (The rule works).
  • If not obvious, what U expected to happen:
    The group function should works fine in all units of HIPS.
  • If a software compatibility problem have U tried the conflict FAQ?:
    It does not look like a software compatibility problem.
  • Any software except CIS/OS involved? If so - name, & exact version:
    HashMyFiles(HashMyFiles: Calculate MD5/SHA1/CRC32 hash of files), 2.01
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    Guess : it is a(n) bug/issue of CIS.
    Try to fix it : Add “C:\WINDOWS\explorer.exe” into “Protected COM Interface” of HashMyFiles’s Exclusions without using group.

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration:
6.3.294583.2937, Firewall

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    Firewall only, HIPS=safe, Firewall=Safe
  • Have U made any other changes to the default config? (egs here.):
    Uncheck : program auto updates, show desktop widget
    Check : alerts verbose mode
  • Have U updated (without uninstall) from a CIS 5?:
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS:
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows XP, SP3, 32bit, admin & limited, No virtual machine was used.
  • Other security/s’box software a) currently installed b) installed since OS:
    a = Avira Free Antivirus 2013/08/30
    b = No

[attachment deleted by admin]

Thank you for reporting this issue.

Please attach the diagnostics report and a list of the processes running on your computer to your first post. If you have any questions, or need any assistance, please feel free to ask.


PM reminder sent.

Sorry for the late.
I take some time to find out what the "diagnostics report" is, and how to get it.
I can't install Killswitch, so the "processes list" comes from ProcessExplorer(*), is that ok ?


That’s fine. All that was really needed was a list of the processes. I just mentioned KillSwitch specifically because it’s more likely that most users will have that on their systems.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

The devs have informed me that they do not consider this to be a serious bug. The reason is because svchost.exe or any other process which is accessed through COM is protected by default. Thus, this is not needed.

If you have any questions please feel free to respond. However, for now I will move this to Resolved.

Thank you.