GRC's DNS Benchmark....can't get the firewall settings right

I’ve been trying to play around with the DNS benchmark and since it checks a lot of external DNS servers I wanted to just allow it to talk to ANY external DNS servers. Well for some reason that is NOT working, a pop up comes up for every stinking DNS server its trying to connect to?

I have created a firewall rule that allows it to connect from UDP, source: ANY, Desination: ANY, Source port: ANY, Desitnation port: 53

Why am I still getting pop ups asking me to allow or deny this? When I read the rule it says " Allow UDP Out From MAC Any to MAC Any Where Source Port is ANY and Desination…

This is driving me NUTZ!!

When the pop up does come up I hit allow and remember just to make sure I’m making changes to the correct rule. I just changed the rulle to allow any any and pops ups still come up. For the first time I’m getting to the point of removing Comodo. If the rules don’t work what good does the firewall do?

Any ideas on what I’m doing wrong?

Thank you in advance

What mode do you have the firewall in?

I run Safe Mode with the Internet Security configuration and have the Stealth Ports Wizard set to stealth my ports to everyone. I can run the DNS benchmark without a single alert.

The firewall is in Custom. I have the DNS program added to trusted apps. I’m just wondering why when I allow any any to destination port 53 I still get pop ups from the firewall.

I’ll set the FW to safe mode and see what I get.

It did work fine with the FW in safe mode. This is the only program I can’t get to work when the FW is in Custom policy mode.


Is the pop up for svchost.exe?

No, the popup was for dnsbench.exe