Graphic icons not displayed on some websites - especially Yahoo Mail

Hello,

I have noticed a problem when using Ice Dragon with some websites in that those that use graphic icons are not displayed. Not sure of a better way to explain so I am attaching images to show what I mean. For instance, with Yahoo Mail, both Firefox and Pale Moon will display the icons correctly, but Ice Dragon instead displays a box with various letters/numbers inside. It’s not an issue related to add-ons as I have disabled them and started Ice Dragon in safe mode, but the problem persists.

Is there anything I can do in order for Ice Dragon to display those icons properly?

Thanks!

[attachment deleted by admin]

I can view properly in my CID. No problem at all

http://i.hizliresim.com/vzBLOm.png

Is there perhaps some setting or something in the about:config that needs to be toggled for pages to be displayed correctly?

Hi KenK13,
Try disabling ‘Use hardware acceleration when available’, found under general browsing of the advanced options tab.

If the above fails, try with all add-ons disabled.

Kind regards.

Thanks for the suggestions captainsticks,

Unfortunately, disabling hardware acceleration didn’t have any effect. Nor does disabling add-ons. Pages continue to be displayed as shown in the images I attached previously. Also doesn’t matter if I’m using the laptop or the desktop.

Yahoo! uses a custom font for buttons like reply and forward, and if the font is blocked or if you do not let sites choose their own fonts, these may be replaced by “character not found” symbols (a box with 2 rows of 2 characters).

There are a few things you should check to make sure IceDragon’s default settings haven’t been changed.

  1. This is probably not the cause of your problem, but to be on the safe side check to make sure you are using the default theme. Bring up the Add-ons Manager, then click on Appearance to see if you are using the Default 26.0.0.2 theme.

  2. Check to make sure you are allowing websites to choose their own fonts. Go to Tools > Options > Content : Fonts & Colors > Advanced… Make sure there is a checkmark in the box that says “Allow pages to choose their own fonts, instead of my selections above”

  3. Check to make sure you are allowing websites to download fonts. Type about:config in the address bar and press Enter. Click the button promising to be careful.

In the search box above the list, type gfx. If the gfx.downloadable_fonts.enabled preference is bold and user set to false, double-click it to restore the default value to true.

If you had to restore any of the above three items to default, check the problem website to see if your problem has gone away.

If not, then the next option would be to delete or bypass IceDragon’s Cache.

Use Ctrl+Shift+r to reload the problem page fresh from the server. You should see a spinning green circle or some activity in the tab showing that it is reloading, only this time it will be loading the page from the website not from your cache. If this corrects the problem then you need to clear IceDragon’s cache completely using: Tools > Options > Advanced, click the Network mini-tab > Cached Web Content : “Clear Now” or if you don’t see any activity in the tab when pressing Ctrl+Shift+r, clear the cache and see if the problem goes away.

If your problem has still not gone away, you should try removing the website’s cookies. While viewing a page on the problem website, right-click on the page and choose View Page Info > Security > “View Cookies”. In the dialog that opens, you can remove the site’s cookies. If you remove the cookies for Yahoo! Mail, you will lose you log-in security image and will need to recreate that.

If none of the above solves your problem, then you can always use the shotgun approach. One of the following methods should work.

Since I don’t know how much customization you have done to IceDragon you can try resetting IceDragon. Go here to see how to do that: https://support.mozilla.org/en-US/kb/reset-firefox-easily-fix-most-problems
You should be aware that you will lose some settings and customizations as listed on that webpage.

If you would rather not lose any customizations or settings, you should try installing the portable version of IceDragon. Then before making any changes or installing any add-ons, go to the problem website and see if it displays correctly. If you’re already using the portable version and have this display problem, then install the non-portable version and see if the problem goes away.

“Thanks” for this “functionality advice”, but…

  1. I’ve never used and I’d obviously never use Yahoo! (won’t answer any questions regarding this). :stuck_out_tongue: :slight_smile:
  2. Allowing websites to use their own fonts / allowing your browser to use “temporarily” downloaded fonts means your system can be seriously compromised (injected / infected) by itw-malware. So, I’d rather not recommend following your advice if not totally necessary, sorry. :slight_smile:

Kind regards, REBOL.

Take care, nice people. :slight_smile:

MorphOS REBOL,

Since these settings are the default setting for both Firefox and IceDragon, I would have to say that the vast majority of users have never changed these settings and are allowing websites to download fonts and have been for a very long time.

Regards,
gs22

Being “set by default” does not necessarily mean “the most secure setting”.
Being part of the “vast majority” does not necessarily mean that this commonly used “set by default” “interactive” (as I’d call it) handling of websites makes certain browsers acting “more secure”. It does not, in fact.

I’m in no way trying to be a moral “judge” on your advice. If one is using “Yahoo!” by “intention”, it might be a rather “convenient thing” to follow your advice, even if that being a rather “dangerous” thing.

My personal advice, though, would’ve to be to DEACTIVATE any of them “interactive” browser settings. (There are many of them, btw.)
Rest assured, I’m not just saying that for “fun”, “vanity” or “know-all attitude”.
Many of those “default settings” are hurting people’s right to privacy and, furthermore, make them totally vulnerable towards MITM attacks and the like. I’m not joking here, I can be “seriously” serious, as some of my few friends over here might already know. :slight_smile:

I’d rather not follow your advice, so to speak. Please don’t take that as a personal thingie, though. I do care about anyone’s privacy rights, including yours. :wink:

Kind regards, REBOL. :slight_smile:

I’m all for security and privacy as long as it doesn’t break the websites I want to visit. Obviously, Comodo feels it is not necessary to change the default value for gfx.downloadable_fonts.enabled to false, probably because among other reasons it will break some websites and they will get a lot of complaints. I have verified that if you change gfx.downloadable_fonts.enabled to false, the Yahoo! Mail website will have display problems as KenK13 has described and his images show. However, we won’t know if that is the answer to KenK13’s problem until we hear back from him.

Using embedded web fonts can be dangerous (possibility of new exploits), as has been proven in the past more than once.

See also here:

There are a few additional, more technical, reasons to avoid using embedding fonts rather than the ten or so "standard" fonts. One is that it presents a vulnerability to viruses, such as a vulnerability that experts discovered a version of MicroSoft's Internet Explorer. While that particular vulnerability is now fixed, embedded fonts remain potential target for further malware attacks.

Kind regards, REBOL. :slight_smile:

GS22,

Your detailed post was very much appreciated. I discovered that Allow pages to choose their own fonts, instead of my selections above was indeed disabled. Upon selecting it again, the page is displayed as it should.

In addition, gfx.downloadable_fonts.enabled was already configured as “true” so, that wasn’t a problem for me in this case.

Many thanks for your help!

Cheers,

K.

Thanks for your comments, KenK13.

And thanks for posting what worked for you.

gs22