GPRS issue with Comodo firewall

I recently downloaded the Comodo firewall and installed it. I use GPRS over a Nokia phone via bluetooth (a Kensington bluetooth dongle). Comodo recognizes the WAN (PPP) connection and shows the appropriate IP address. However, no traffic at all will pass to the internet. I’ve tried setting the firewall to allow all, and no luck. I went into the advanced tab and turned off everything I could. I even exited the firewall, and no traffic would pass. When I uninstall, everything works fine again. I’ve done this 3 times, same results. The Windows firewall is off. If I try and ping something, I get a destination unreachable error. I even tried to sniff the interface to see if traffic is leaving, but it doesn’t appear traffic is making it to the interface. When I start up internet explorer, I don’t get a pop-up asking if internet explorer can access the internet. Anyone have any thoughts?

Does anything show up in the logs as being blocked when you try to make a connection? If something does show as being blocked you need to make rules to allow it if you know it is from the connection attempt. Make sure the rules are above any block rules.


No, nothing is logged. I set rule #1 (allow TCP and UDP traffic) to log, so I could see if the DSN was trying to make a connection and was being denied. But if it was just a rule, then things should work when I set the firewall to allow all, or when I exit the application.

BTW, I forgot to mention I’m running Windows XP home edition.