Google Desktop Browser Being Blocked


After installing CPF, I can no longer get the search results from Google Desktop in my browser window. I searched the forums and found some possible thoughts but none seemed to work.

The address being blocked is:

I tried creating rules for this IP/Port combo but no good results.

Shutting down CPF makes it work fine.

The browser is Avant but problem exists in IE and Firefox as well.


But, that address… is localhost (ie. you). Are you running some sort of proxy? Also is there anything in CPFs logs…


Yes, thats the part that confuses me! I tried again just now and no new CPF log entry appeared. I am not running any proxy server, very basic laptop wirless connection to home router. But if I shut down CPF, Google works fine.

I see Google Desktop as having an open network connection with adddress of on port 4664 with TCP/In and another entry with ports 1132-4664 with TCP/In/Out.

Any thoughts ?

Thanks very much.

Allow CPF to skip local loopback (127.X.X.X) connections and GDS should start working again. Lots of programs use the local loopback, FF in particular.

Hope this helps,
Ewen :slight_smile:

I must be extremely slow today :slight_smile:

I added the rule below:

Allow thru TCP/UDP In or Out with source and destination port set to any and I still am unable to show the page. I moved this rule to the top of my rule set and logged it but it doesnt trip.

Do I need to do anything to get the rules re-loaded in CPF ?

Thank you

If CPF is stopping something, then it is in the Log. Find the blocks, export your log to a file & cut ‘n’ paste the offending block(s) to here.

Open CPF, click SECURITY - ADVANCED - MISCELLANEOUS and slec both of the “Skip loopback” options. Remove any rules you created trying to emulate this, reboot and you should be OK.

Ewen :slight_smile: