Google Chrome is not contained in green border while being sandboxed [M1066]

A. THE BUG/ISSUE (Varies from issue to issue)
Can U reproduce the problem & if so how reliably?:
Yes, Every time.
If U can, exact steps to reproduce. If not, exactly what U did & what happened:
1: Run Google Chrome under “Fully Virtualized” or “Partially Limited” or “Limited” or “Restricted” or “Untrusted” restrictions.
One or two sentences explaining what actually happened:
Google Chrome is not being shown with green border. However, it is successfully sandboxed.
One or two sentences explaining what you expected to happen:
Comodo Internet Security will show a green border around programs that are running in the sandbox.
If a software compatibility problem have you tried the conflict FAQ?:
N/A
Any software except CIS/OS involved? If so - name, & exact version:
Google Chrome 35.0.1916.153 m.
Any other information, eg your guess at the cause, how U tried to fix it etc:
I’ve switched to Windows Classic theme - the issue persists.
I think that this issue started from an older version of Google Chrome. I’ve tested it with version 35.
I’ve reseted sandbox- the issue persists.
I’ve removed ALL extensions and disabled ALL plugins from Google Chrome- the issue persists.
chrome.exe minidump+fulldump & killswitch csv
B. YOUR SETUP
Exact CIS version & configuration:
7.0.317799.4142
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Default Configuration.
Have U made any other changes to the default config? (egs here.):
No.
Have U updated (without uninstall) from CIS 5 or CIS6?:
No.
if so, have U tried a a a clean reinstall - if not please do?:
N/A
Have U imported a config from a previous version of CIS:
No.
if so, have U tried a standard config - if not please do:
N/A
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
OS: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.140303-2144)
UAC: Disabled
Account type: Administrator
V. Machine: Not used
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=None b=None

[attachment deleted by admin]

Thank you for reporting this issue. From what I understand, you have set Google Chrome to always run virtualized. However, when it is you find that no green border is shown around it.

However, what happens if you manually right-click on the executable for Google Chrome and select Run in Sandbox? Is a green border shown for that situation?

Thanks.

I think this issue started from an older Google Chrome version. I’m not sure.
The mode you described was my first attempt to sandbox and I noticed there is no green border.
Right-click on Google Chrome > “Run in COMODO Sandbox” → “Fully Virtualized” mode.
After that, I’ve tried to set different restrictions just to see what happens and apparently every restriction level is affected. Sandboxing Google Chrome in every possible mode will leave to no green border (same result).

I’m also curious if other users are experiencing this or is it an isolated case.

Used to have the same issue but they fixed it for me in one of the recent versions, can’t remember which one, but it has been fixed for me since.

qmarius, can you please create a diagnostics report and attach it to your first post. Also, please attach a KillSwitch Process List. In addition, use KillSwitch to create a Full Dump of Google Chrome (while running sandboxed). Then put that dump file in a zip file, upload it to a file sharing site, and paste the download link in your first post.

Let me know when you have completed this, or if you have any questions.

Thanks.

Done.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time, availability, and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Hi qmarius,
I am not experiencing this issue.
Note: Not sure if it is relevant or not, but I have Chrome portable only.

Kind regards.

@qmarius

I think this is related with

https://forums.comodo.com/format-verified-issue-reports-cis/no-green-border-around-comodo-dragon-when-sandboxed-fv-m958-t103452.0.html

Chromium has a problem with Comodo sandbox.

Hi christarzan,

Yes, it is. Dragon is based on Chrome.

P.S. : I think these two bug reports should stay parallel.

Thank you for pointing that out.

Hi,

The issue is present in the portable version of Chrome.

Thank you.

I found another application with no green border while being sandboxed. Attached.
(It’s a game launcher/updater.)

// see Bug 1610

[attachment deleted by admin]

qmarius, the information I have at this point shows that this is likely going to be fixed in the next update. Thus, after the next version is released please check this again. If a green border is still not shown please let me know.

Thanks.

Thanks, Chiron. If you can, please forward other applications that I attach because these refer to the same issue.

Thanks again.

I will do so if this is shown to not be fixed in the next version. I’m really hoping it will be fixed all around.

Ping

The expectation is that this will be fixed in the next update. However, I am not sure when that update will be.

Hello Chiron,

The same bug exists in beta 8. I can get the green border around firefox but not around Google Chrome or any Chromium based browser.

Thank you for letting me know. I have added this information to the tracker.