good news for windows 7 users

Wow. Apart from the silly insults etc you have been making in this thread, I can confirm that Comodo Firewall does NOT work in Windows 7.

Yes, it will install just fine if you know what you’re doing. It will even APPEAR to be working.

However, unless you’re an idiot, you can easily tell it’s not working properly. Stop confusing people.

I’ve been using CPF for about 2 years now, so I know my way around it quite well. After installing, I was wondering why it only had block/allow popups for some programs, and not others. I checked my settings, and sure enough, I had it set correctly (for me) to ask for EVERYTHING that I had not made a rule for. I tried Firefox - no popup, but there was no allow/block rule either. Hmmm. So I tried AVG update - yep THAT got an allow/block popup. Strange, I thought. Popup for one thing, but not another, and neither had any rules set.

So I tried another way - I installed Ventrillo. Opened it up - no popup, and it had internet access. Ok, I’ve got it - I then set a “block all” rule for Ventrillo. Opened it up, and it had FULL access to the internet still. Conclusion - Comodo is NOT working with windows 7. (Not the developers fault, they haven’t released a version yet that is supposed to be compatible). So for the love of god, stop saying it works when you don’t know what you’re talking about, or even how to do a basic test.

Just because it installs, starts up fine and doesn’t give any errors, doesn’t mean it’s actually working properly.

On a side note, I eagerly await a version of Comodo that works with Windows 7. I really like how reliable Comodo’s firewall is, although the rules list could be laid out a bit better - it was much better on CPF 2.XX.

Hello All

Please Remember to Follow The Forum Policy

Comodo forum participants have different backgrounds and views. Flaming each other helps no one and is not tolerated by Comodo staff, moderators or ordinary forum members. Hostile or derogatory messages directed to any person (flames), along with other posts written for the sole purpose of [u]antagonizing[/u] others or starting an [u]argument[/u] (flamebait), will be edited or removed at the moderators' determination. If a topic was opened with the same purposes it will be locked or removed without any further notice. If any topic turns into an argument it can be splitted, locked or removed without further notice. Members who continue to post in this manner or any other questionable manner that violates these forums policy (trolling) are subject to more serious disciplinary actions. Since Comodo strives to host an open and multicultural forum these boundaries are only meant to preserve this open environment.
----------------------------------------------------------
......Members discussing or inciting illegal activity, posting or requesting anything illegal or [u]inappropriate[/u] will be warned or banned as appropriate

- Jacob Kilgore
C-O-M-O-D-O Forum Moderator

ShastaNZ Newbie * Offline Offline

Posts: 1


I think someone is trying to start a flam war, your not going to find it here :slight_smile: And if the topic starter had a half a brain, this person should have known that writing about the CIS in Comodo System Cleaner section is in the wrong spot

Either way I vote for ban on “ShastaNZ” :-TU :BNC

I vote for ban on you! :-TU :BNC :stuck_out_tongue:

Just kidding!

[at-bypass]ShastaNZ: It could be that you were looking at the rules for D+ but there already was a allow connection rule for Firefox in the Firewall section.

Because CIS works just fine in Win7 for me.

Apologies no flame wars intended here, I just had to reply to the OP and his increasing…stupidity…

Not to mention the fact that many people seem to assume that if a program installs successfully it means it’s running fine too.

Oh trust me, I’ve been using CPF / CIS for a long time now, I know my way around it just fine. Besides, I de-activate / don’t install the defence plus side of it, nor do I go into that section.

The issues I had were on a clean install of Win 7, I only had Firefox and a couple of other things installed - I hadn’t even installed any anti-virus at that stage. I thought it was not working properly, and when I installed Ventrillo, ran it, and no block/allow popup ever came up (I ALWAYS have CPF / CIS set on custom mode to ask for EVERY program that I have not personally set a rule for) yet it had internet access. Then to test it I closed Ventrillo, verified there were no rules that had “magically” set themselves for Vent, set a rule to BLOCK Ventrillo, yet when I ran Vent again it had full access to the net - even while I was looking at the CIS rule to BLOCK Vent.

Short of writing a full essay and step by step guide on my findings, with screenshots and video footage, I cannot make it any clearer that I am VERY experienced with computers and software, am VERY familiar with CIS, and I was sitting there watching a CORRECTLY blocked program access the internet.

“intransigence” may have been a nicer term to use. :wink:

Then to test it I closed Ventrillo, verified there were no rules that had "magically" set themselves for Vent, set a rule to BLOCK Ventrillo, yet when I ran Vent again it had full access to the net - even while I was looking at the CIS rule to BLOCK Vent.

Just to clarify, if you create a new rule for an application or a connection, you need to click APPLY in the rule creation window for it to appear in the global rules list AND you then need to click APPLY in the global rules list for it to actually be parsed by the FW engine. Until the second APPLY is applied the rule exists but isn’t activated.

I’m assuming that when you say “even while I was looking at the CIS rule to BLOCK Vent” this was after you had clicked the second APPLY and had gone back into the Global Rules window.

Cheers,
Ewen :slight_smile:

Yes, yes, yes, and…

yes.

I thought I had made it clear I know how to use CIS. Forgive me for omitting the “apply” detail. I figured it was implied by saying “I created a rule”, in the same way that it was implied that I followed the steps to open a “create new rule” dialogue in the first place, entered a name for the rule, browsed to the correct exe file, clicked “ok”, set the rule as a blocked application, etc etc. Saying “I created a rule to block it” and expecting you guys to assume I was not pants-on-head ■■■■■■■■ was just quicker and should have been enough lol.

Thanks for the reply. PM sent, please check your inbox.

Cheers,
Ewen :slight_smile:

I always wonder what is happening when a mod says, “check you PM’s”. ;D

[at-bypass]ShastaNZ:
What Win7 build are you using? I’m using 7000 still…too slow connection to upgrade/update. :slight_smile:

My printer and Camera drivers won’t load with Win7 x64. Both drivers are the most recent. Until that is resolved, I removed Win7 x64.

Dunno, whatever the latest version is I guess. 32 bit. I let it update whenever it needs to. Mostly they seem to just be windows defender updates though, but the odd actual OS update is released now and then…

I had the problems about a month after the Beta went public, that’s when I first installed it and attempted to run CIS. I got it installed fine with the “run as” and compatibility tweaks etc, but then I noticed the unreliable behaviour. I’m not criticising it though - it wasn’t designed for win 7, so I can’t complain it doesn’t work with it. It’s possible it works now, although I doubt MS has released an update for win7 that fixes an issue for CIS to allow their firewall that wasn’t even designed for Win 7 to now suddenly work. Like I said, it APPEARS to work, but upon closer inspection it is completely unreliable.

I doubt MS has released an update for win7 that fixes an issue for CIS to allow their firewall that wasn't even designed for Win 7 to now suddenly work
I'm not sure if this would help, but if your using windows 7 version 7000. Have you considered trying out windows 7 version 7057? Some things have improved. That's what I'm currently using :)
and his increasing...stupidity...
and "intransigence" may have been a nicer term to use. <---I agree with this, but that may have been too big of a word to write. <---You know I'm kidding, just like you were kidding about "stupidity" LOL
ShastaNZ: Would you like to hear about my opinions? I'm betting that you don't :■■■■ LOL

People have problems with CIS with Windows XP, Vista, and Windows 7 (windows 7 is no different) that’s the price you pay when your playing with beta software >:-D

I can confirm that Comodo Firewall does NOT work in Windows 7.
Just because Windows 7 and CIS doesn't work for you, that doesn't mean it's not going to work for anyone else with the same Operating System. Theres people that can't get CIS working with Vista, does that mean CIS does not work in Vista.

I hope your able to fix the problems your experiencing. I wish you the best of luck :slight_smile:

I already said I’ve been letting it update - unless the updates are secretly just pictures of MS workers grandmothers, I’m going to assume that each update brings the version number up to date - version 7000 updated regularly = version 7xxx.

EDIT: Upon further research, it’s possible that 7057 does have components that are not included in the updates. However, as I am trying to contribute to the Beta program, I won’t be downloading any leaked torrent versions of Win 7 - which is what that 7057 appears to be - I’ll be sticking to whatever “official” Beta MS has released for testing. That’s kinda the purpose of Beta testing, not going and getting whatever random leaked unofficial Russian hacked build is around. If or when they officially release a new version for testing, then I’ll get that build.

Again, I already said that too:

The more logical conclusion was that you did not test it properly or thoroughly. The people that can’t get it working usually don’t know about or how to do the “run as admin / vista compatibility mode” etc, or have their UAC settings too high etc etc. Believe it or not there are some people out there that don’t know much about computers but mess with them anyway.