Global Rules

When I put the global Rule “Block and Log IP in/out from MAC any to Mac any where Protocol is any”
in top Positon my Internet connectivity is not completly blocked
Firefox shows some pages others not
Do I have to make other adjustments?

That will only block new connection requests, current existing connections will still be allowed, to block all network activity use the stop network activity task or set firewall to block all mode.

I don´t understand why Firefox shows some pages ,others not
What is the Difference?

Just a guess, maybe the pages you see in Firefox are stored in the Firefox local cache browsing history.
Try clearing the cache and the browsing history in Firefox (in Firefox press CTRL+SHIFT+DEL and select the items you want to clear) and then try to visit the pages again.
Do they still show up now?

Sorry, ignore my previous post!

I observe the same behavior in v12.0.0.6882

When adding a FW Global Rule to block everything then Firefox is still able to visit (and all google related pages such as google maps and google translate) even after clearing everything in Clear All History in Firefox. Pages like or and others are correctly blocked.

Even worse is that the FW View Connections window stays empty when Firefox connects to google.

Even setting Firefox’s file rating to Unrecognized and removing the Firefox FW Application Rule still allows Firefox to connect to without any FW popup alerts!!!

So valid questions are:

  • Why is Firefox allowed to connect to when a FW Global Rule is in place to block everything?
  • Why stays the FW View Connections window empty?
  • Why are there no FW popup alerts?

Is this a serious FW leak or is it by design???

Thank you.

If your ISP provides IPv6, then you are most likely connection over IPv6 which the firewall by default does not filter, you need to enable IPv6 filtering in firewall settings.

Ah thanks for pointing out ipv6 filtering, it was indeed disabled by default setting.
The FW Global Rule to block everything now works correctly, Firefox does not connect to google anymore.

All well!


i use comodo firewall to prevent ip leaks in windows with a vpn when i enable ip6 filtering
my vpn does not connect

Maybe as a workaround for your vpn with enabled IPv6 filtering (I’m not sure if this works though) but you could try to add a FW Application Rule for your VPN and block all IPv6 addresses and then check if your vpn does connect.