Global Hook Alerts


Every time I open an application (not recognized by CIS), I am prompted with a Defense+ global hook alert (see screenshot). Is there any way to surpress these alerts as Nview.dll is a trusted process (from Nvidia).

I’ve tried adding nview.dll to my trusted list but it doesn’t seem to make any difference :(.


[attachment deleted by admin]

have you tried to answer : “treat this application as trusted application” (and “remember my answer”) when this message prompt ?

Adding nview.dll to global hook allowed exceptions for All applications * policy might do the trick.

Yes, but this only works for the parent process (i.e VLC) rather than nview.dll itself. Every other product (trusted or not) will still prompt due to nview.dll wanting to hook into every process.


Thanks, I’ll give this a try and see if this works. I’ve tried disabling Nview but the settings don’t seem to hold (i.e becomes enabled again ??? )


Try this: in Defence+ go to “My Trusted Software Vendors” and there press “Add” and “Read from a signed executable” and select your DLL. When this DLL is signed, it will be add to the trusted Software list and the alerts in Safe mode should be gone.

I have the same problem and your suggestion does not work.
Do you have another one?

Thiese silly alerts are driving me nuts.
I have just installer google chat service and google wave and it keeps on coming up.
It looks like Comodo is NOT remembering the instruction I am giving!

Are you ticking to always remember that answer? What browser are you using? Are you by any incident running the browser from a USB stick?

I have the same problem. Running from hard drive, Win XP SP3. I submitted the “suspicious file” to Comodo, but I still get the pop up all the time. Not sure whether to get rid of Comodo, Nvidia video card or what. It’s been happening since I installed Comodo a few months ago. You would have thought that they would have sorted it?

I got here by googling the problem.

Since you know if is an alert for an NVIDIA application, a source we can trust, I suggest to remove the file from My Pending Files by making it one part of My Own Safe Files. Select the file in My Pending Files → Move to → My Own Safe Files.