Get browser key on keyboard to open Comodo Dragon?

Hello,

I’m using a Ducky Shine 2 and it has four keys up to the right that I often use, those being Calculator, explorer, Mail and Browser (at least I think it’s browser, might just be home page)

With Google Chrome set as default application, the browser key on the keyboard will open Google Chrome. With Comodo Dragon as default application, the browser key on the keyboard will not do anything, however if Comodo Dragon is already running the key will take the current page to the “New Tab” page…

  • Google Chrome set to default application & Google Chrome running, the browser key will redirect the current tab to the “New Tab” page.
  • Google Chrome set to default application & Google Chrome NOT running, the browser key will start Google Chrome.
  • Comodo Dragon set to default application & Comodo Dragon running, the browser key will redirect the current tab to the “New Tab” page.
  • Comodo Dragon set to default application & Comodo Dragon NOT running, the browser key doesn’t do anything.

What I want is the browser key to start Comodo Dragon, since this has been the primary way for me to start my browser for a very long time now and it would be hard to change that behaviour.

Does anyone know the registry key that needs to be changed/tampered with to accomplish my wish?

Regards,
Sanya IV Litvyak.

Okay so nobody seems to know, does anyone know any kind of program that I could use to find out exactly what the key does? For example if I press the browser key that does this and this which leads to this and this and hence that and that happens… I’m never going to get it to open dragon, am I?

Hi SanyaIV,
I do not have a browser key to try it.
You maybe able to add the browser key to the ‘shortcut key’ field in Dragons shortcut properties.
It may show up and require Ctrl+Alt+Browser key.

[attachment deleted by admin]

I tried that but it didn’t work, in fact I can’t get any shortcut to work with any shortcut key :-\

I found out which “defaults” that decide which program starts when I press the browser/home page key, it’s the HTTP and HTTPS defaults, see image.

Does anyone know which registry key it is that defines which program should start? I think it might be messed up for Comodo Dragon?

[attachment deleted by admin]

If I am understanding this correctly, can’t you just uncheck them for Chrome and then select them under Dragon?

Well I can, and then we’re back to the issue that the button now doesn’t do anything.

If ticked for google chrome and you press button then google chrome opens, if ticked for comodo dragon and you press button then nothing happens.

- Google Chrome set to default application & Google Chrome running, the browser key will redirect the current tab to the "New Tab" page. - Google Chrome set to default application & Google Chrome NOT running, the browser key will start Google Chrome. - Comodo Dragon set to default application & Comodo Dragon running, the browser key will redirect the current tab to the "New Tab" page. - Comodo Dragon set to default application & Comodo Dragon NOT running, the browser key doesn't do anything.

OK sorry my mind wandered away temporarily. :wink:

So since this works with Google Chrome, FireFox, Internet Explorer, Opera 12 and Opera 16… but not with Comodo Dragon, I can only come to the conclusion that there is something wrong with how Comodo Dragon handles being the default application for those protocols.

Would there be any other way to do this? Like AutoHotKey? I just don’t know how to use that program, I also don’t know what this key is registered as, if it is even possible to bind it to something.

Edit: Tried AutoHotkey but I have no idea how to bind it to the browser button since I don’t know what the browser button has for like… code? I mean, I think the windows button was represented by “#” and the n button by “n” but I don’t know what the browser button is. I even tried using a keylogger to get it but nope, doesn’t show anything and Zemana’s keylogging simulation thingy says it’s a virtual keyboard input thingy…

So I can only assume that the key actually sends a command to open http or something however Comodo Dragon doesn’t replace the line that handles this correctly and hence nothing happens… is my best guess, probably way off.

…try this Sanya - RIGHT click Dragon icon - properties - click in the “shortcut key” box to activate cursor - “HOLD DOWN” windows key (the one with the little flag in the bottom row) & press the key you want to to use to open Dragon - continue to hold down windows key to click “apply” & “ok” - if it does not work with your special “browser” key, it should work with one of the “F” keys at the top of the keyboard - you should be able to use this method with any program ie. CCleaner, defragger, or whatever else you use and want to open with a key…

P.S. oh yeah, do you run the “full” version of Dragon or the “portable” version? Maybe it won’t work /w/ portable, & needs to be an “installed” program…

When holding down the windows key I am unable to input anything into the box.

Which pretty much defeats the purpose of this thread, I want to be able to open it with the browser button, if I wanted to use any other key I’d just make an AutoHotkey script.

Full version.

download this
http://directedge.us/content/winhotkey

1)instal
2) open winhotkey
3) click on “new hotkey”
4) remove checkmark on windows
5) agree to the warning
6) scroll down untill you find the word “home”
7) click on “browse”
8) find comodo dragon
probably located at
C:\Program Files (x86)\Comodo\Dragon or whereever the main .exe file is (mainly if your using portable software)
click on the .exe file
click ok

now see if it works

Well that would work, if Home was the key I wanted to use :stuck_out_tongue: The key is a non-standard key. The key opens something related to html which works with Google Chrome but not Comodo Dragon. =/ (also tried AutoHotKey)

Edit: Bug report made here: https://forums.comodo.com/bug-reports-cd/internet-button-on-keyboard-doesnt-work-correctly-with-comodo-dragon-t101488.0.html