GeekBuddy Produck Ask Toolbar Error

Hey there, I got this annoying problem. GeekBuddy keeps popping up with error message “Product: Ask Toolbar – Error 2753. The File ‘taskscheduler.exe’ is not marked for installation”. Someone suggested to uninstall and remove Ask Toolbar, but I can’t find an entry for it under Control Panel → Add and Remove Programs. I have found something called Ask Toolbar Remover which is an Ask Removal Tool designed to remove all entries of the Ask Toolbar (tested for 4.0.x, 4.1.x, and OEM 1000) and to reset your homepage from to if it was changed to and tried that, but didn’t seem to work. I am wondering if someone here can help me fix this problem.

Try installing Ask Toolbar and then unistall it. That may work. Download it from: .

I just tried that suggestion and when I went to run the Ask Toolbar Installed, it ends up giving me this message “Unable to Complete Installation. We have detected that you already have a Toolbar powered by Ask.” and then closes. In Add or Remove Programs, there is still nothing called Ask installed.

Let’s try a manual approach here.

Are you familiar with using Regedit? If you are not check out this tutorial on how to start it.

Then navigate and delete the following registry entries:

Select one of the above entries and delete it. See attached image for reference. When you selected a key as seen in the picture push the Delete button and confirm or right click and choose Delete and confirm.

When you are not experienced with working with the registry make a System Restore point before removing these keys.

Let us know if this of help for you.

[attachment deleted by admin]

Alright, I went into Regedit and deleted HKEY_CURRENT_USER\Software\ However, HKEY_LOCAL_MACHINE\SOFTWARE\AskToolbar and HKEY_USERS\S-1-5-21-4155921847-2839181805-2297933737-1001 paths do not exist. And I still have that error message popping up from GeekBuddy.

ask the GeekBuddy experts to fix it for you…

just click on chat and let them do it for you…


I have already did that before I posted here and they suggested uninstalling Ask Toolbar which did not work.

Well, I just recently connected with a GeekBuddy expert Michael and he remotely connected to set a System Restore Point, then looked at something in my Add or Remove Programs, then did some cleaning of my IE Settings, then did some registry cleaning of invalid entries, and then rebooted my computer. Apparently after the reboot and the expert has already disconnected, the Geekbuddy popup showed up again with the same error message.

pls connect and ask them again to fix…thx