Geekbuddy PoP Up

this started popping up today. Haven’t found a way to disable or uninstall it. I don’t have the Geekbuddy app installed. Any idea how to stop this?

Hi scratch67. Could you help me to understand your issue better so that I can help you with it.


There should be a checkbox in the lower left corner to prevent it from showing up.

I also have this problem.
I don’t have GeekBuddy application installed.

When Geekbuddy message shows up i choose checkbox “don’t ask next time”, but this not working.
This message continued to shows up when comodo finds a virus. it is become very annoying.

And this is NOT 1st April joke.

[attachment deleted by admin]