GameTap games unable to launch

Since upgrading from Comodo v2 to v3 I am no longer able to launch GameTap games, which now immediately quit with error messages (“Internal Error has occurred” or “File corrupted ! Please run a virus-check, then reinstall the application”, depending on the game).

The problem definitely stems from Comodo; I tested this by uninstalling it and running GameTap again–games launch and play perfectly. Upon reinstalling Comodo, however, these very same games have error messages.

I am running the latest version of Comodo Firewall Pro ( on XP Home SP3 (32-bit) as an administrator. All Comodo settings are at their defaults (this is a fresh install). I have tried adding GameTap’s files to the safe list and setting gametap.exe as a trusted application, but the error messages still pop up (the game files are not directly accessible so can’t be easily added to the safe list). I have tried turning off Defense+ (with the “permanently” option and then restarting as required) to no effect.

GameTap works by mounting disk images to the drive letters X: and Y:. The GameTap staff have previously said that real-time scanners can interfere with these drives, so I assume Comodo is scanning these drives in a way that breaks the mounting process or is interpreted as a cracking attempt.

Is there some way for me to whitelist these drives so Comodo ignores them altogether? I don’t want to go back to the older Comodo version, but I don’t really want to be without GameTap either…