FYI: Help oddety and Proxomitron


I tried Comodo 3 on my Dell Dimension 9200 with Vista Home Premium and it looks very promising.

However I removed it after only a short “trial” period for two reasons, one of them could be my own fold, the other isn’t.

  1. Clicking any of the Help links, crashes Comodo 3 instantly, without any warning what so ever.

  2. I’m using Proxomitron as a local proxy and to be able to use the internet at all, naturally I have to allow it access. First time Comodo warns me as it should and I gave it permission.

So far, so good. However, there seems to be a catch. Any program that uses the IE proxy setting connects through Proxomitron and they can all happily connect out without any alert from Comodo 3, unless I missed a setting somewhere.

If #2 is by design, you should reconsider the way Comodo 3 is handling outbound traffic when a local proxy is used, because it’s rather useless this way since most programs use said IE proxy setting.

On the other hand, if #2 is a Comodo 3 setting, you’ve done a marvelous job at hiding it. Now that you’ve been given proper credit for doing so (:KWL), you might consider giving it more obvious, easier to find location in the Comodo 3 UI.

Keep up the good work,

  1. This is a known problem and has been fixed in the new release. As a workaround, you can open Explorer and navigate to C:\Program Files\Comodo\Firewall and double-click the .chm file.
  2. This is due to the way that proxies work. The original request for a connection is made to Proximitron which then passes the connection request on. The proxy is thus the originator of the connection request outbound since the original request is a request to the proxy, not the internet. Short of writing a new feature that allows special monitoring of proxies, I don’t think that there is a simple way to change this, unless Proximitron has Logging features?


Indeed nr. 1 is fixed, thank you verry much for that. I’ve ran into one other Help problem:

  • Click Miscellaneous
  • Click Manage My Configurations
  • Press F1

Comodo tries to use cfp.hlp which should be cfp.chm IMO

While there, trying to save my current config, Comodo tells me I don’t have the rights to save to that location. That’s not true, I do have the rights to that locations for sure.

I hope you can do something with this info, again I could be doing something wrong.

Proxomitron has a log window, not sure why you ask.

I’m not sure why this is a problem for you, whether it’s a local proxy or any other app, any program that tries to use an existing program for Internet access should trigger a warning. Local proxies are quite common in various situations and a Firewall should treat them accordingly. Like I said, install a local proxy and the entire outbound protection is down the drain. I’ve dropped other Firewalls for this reason, cause they add to little to the Windows Firewall this way.

ZoneAlarm does catch this, but it takes me an hour to collect a 5kb email. (:SAD)

I really hope you will consider adding local proxy support, Comodo is worth it.

Take care,

The way Comodo handles outgoing loopback connections has been changed in Comodo now alerts you about these connections, and they are governed by application’s network rules. Consider updating your CFP.

Thank you for your reply. I am using the latest version, and between my first post today and your reply, I’ve stumbled upon the loopback setting. I am getting a warning now when an app. is trying to connect through proxomitron.

Great work, many thanks to the design team.