FW not allowing networking one one PC of three

I have three PCs I wish to connect. One rns Win 7 32-bit, my own runs Win 7 64-bit and my wife’s runs Win 10 64-bit (is there a 32?).

The PCs all have CIS installed on them, as far as I know “as installed”, with no mods made by me.

But my wife’s refuses network contact when the FW is enabled. No problem if I turn off the FW. This has me stumped.

Can anyone help with this, please? I started reading a few posts here and elsewhere and many were full of arguments about why suggested ideas were or were not dangerous.

Thanks in advance.

Is it able to get an IP address assigned? If so go to manage networks task and select trust network and click ok.

OK thanks.

Wife’s taken her (Laptop) PC ATM. I will let you know how I go.

OK. Here is my situation. The “Wife” PC is not back yet so I looked at the two I know are networked fine.

Each machine can only see itself and its IPA, but the “network” is trusted. Yet they are connecting OK on the network. From what I understand of those instructions, there are two different IPAs shown, indicating two networked PCs. Am I correct?

The one proviso here is that I am using Homegroup to connect them. Would that allow the connection and bypass the FW?

I ask so that when the offending PC comes home, I have an idea of what to expect when I fire it up.0.

Thanks again for any help.

BTW, I am using Homegroup against the advice of several people, mainly because I discovered that all 3 PCs would connect across OpSyses using Homegroup…as long as my wife’s Comodo FW was off.

Your two computers have your network set to trusted which creates allow incoming global rules from the same local network which allows homegroup to work. So once you set your network to trusted in CIS manage network tasks, it too will have the necessary global allow rules for homegroup networking.

Well…what you say is correct…except that I did absolutely NOTHING to my wife’s PC: as I say it was away all yesterday. She reconnected and…I am able to network with her machine, even with the FW on safe mode.

I hate it when I spend ages and a thing just sorts itself, because I have wasted time and now I don’t know why it sorted.

So, thanks for your efforts. Feel free to explain if you want to put in the time.

I think I have it!

This evening I tried to scan the drive on my wife’s PC and was barred…the machine was asleep. Suddenly it gelled. That was it. I could not access her PC if it was asleep. All this… and IA99%S that I have it.

Of course it worked if I went in there and disabled the FW. I woke up the PC to do it, the scuttled back to my machine and tried again.

Now to sort out wake on LAN Windows 10 :(. The things we do for the love of someone who has no idea…

And yeah I know I sound like one of them…but I want to improve…:smiley:

Got it!..I think. My wife’s PC goes to sleep and is not waked by LAN. So I would get success as long as I tried fast. Then I would try again and fail . Then I would go and change stuff on her PC and of course it was awake and stuff would work…then 5 miins later it would fail. etc.

This might help you: https://www.howtogeek.com/70374/how-to-geek-explains-what-is-wake-on-lan-and-how-do-i-enable-it/

I did try Homegroup for my LAN, but it was so picky with different OS, that I just went for mapping Network drives and I don’t let anything go to sleep - except me :wink:

ARRRRGH! As soon as I read “magic packet” I know there will be trouble…

Thanks for the post and link…