Fully Virtualized Internet Browser saves files outside the sandbox

Currently a bug with the sandbox when downloading from a fully virtualized browser.

it saves the downloaded file to the actual downloads folder and not the fully virtualized one…

it didnt do this before like in previous versions it would save the file in the fully virtualized environment.

tested with Internet Explorer and Cyberfox both the same result.

[s]Are you using Internet Security Config or Proactive Config?

I found the same bug when using Internet Security Config and reported it to Comodo who were able to replicate it, it should be fixed in the hotfix scheduled for first week of June or the release after that.
[/s]
Edit: Not a bug, see response below from airatgab

ohhhh So I should just remove the Downloads Folder path? if yes then haha its gotten more confusing to use I gotta relearn it :stuck_out_tongue:

Edit: It works now thanks :slight_smile: downloaded CCleaner as a test and it didn’t show up on the real Downloads Folder its only in the Fully Virtualized one :).

Im using Comodo Firewall with Avast Free AV, Been using Comodo on and off for 3 years.

I was using PrivateFirewall before but didn’t really like it so moved back to Comodo Firewall.

Currently have Firewall Config on.

I have sandbox disabled cause of that bug.

I can easily use HIPS and Firewall its nothing new to me its really easy to use hehehe for me cause im really good with these things.

in case you are wondering my fully combo is:

Comodo Firewall
Avast Free! Antivirus
Malwarebytes Anti-Malware
Malwarebytes Anti-Exploit
CryptoLocker

A little paranoid but whatever haha.

Huh, you’re right, didn’t see that change.

Please see what airatgab, it’s apparently not a bug, just a change of the default settings that I hadn’t noticed.

I already made the change works perfectly thanks for the help. now I gotta read up on the changes cause haven’t used it in about 4 months.

Am i the only one who find the “naming” of that function to be very misleading?
I always thought “do not virtualize access to…” ment “do not make this location vissible to whatever is inside the sandbox.”
i.e.
“Do not put this area inside the sandbox” and the mentality is that if something have been excluded from the sandbox, the sandboxed application will not know its there.
(but in this case said function is the total opposit)

Instead of “do not virtualize access to :the specified files/folders”
it should be saying something along the lines of these examples.

  1. “Allow sandboxed application direct access to: the specified files/folders”
  2. “The following ares will not be protected from sandboxed applications”
  3. “Exclude protection to :the specified files/folders”

same goes for registry keys/values