Full Scan Doesn't Show Percentage Until Far Into Scan [M42]

When I first run a full scan of my computer the scan percentage does not show up until the scan percentage is above 75% or so. Even the second time it does not show up for a while, although it is less than 75%.


  1. What you did:
    After installing CIS, and letting it run a full scan and then restart, I run a full scan. However, the scan percentage did not show up until after about 75%.
  2. What actually happened or you actually saw:
    It scanned just fine, but the scan percentage did not show up until after about 75%.
  3. What you expected to happen or see:
    I expected the scan percentage to start from 1% and increase correctly to 100%.
  4. How you tried to fix it & what happened:
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)?:
  6. Details & exact version of any software (except CIS) involved (with download link unless malware):
  7. Whether you can make the problem happen again, and if so precise steps to make it happen:
    Just run a full scan with CIS on my computer. This also happens on subsequent scans, although the scan percentage will show up earlier, although by no means from the beginning.
  8. Any other information (eg your guess regarding the cause, with reasons):
    I’m not sure what causes this.
    B. FILES APPENDED. (Please zip unless screenshots).:
  9. A diagnostics report file (Click ‘?’ in top right of main GUI) Required for all issues):
  10. Screenshots of the 6.0 Killswitch Process Tab (see Advanced tasks ~ Watch Activity) or 5.x Active Process List. If accessible, required for all issues::
  11. Screenshots illustrating the bug:
  12. Screenshots of related CIS event logs:
  13. A CIS config report or file:
  14. Crash or freeze dump file:
  15. Screenshot of More~About page. Can be used instead of typed product and AV database version:
    Information provided below.


  1. CIS version, AV database version & configuration:
    Comodo Internet Security Version 6.0.260739.2674
    Database 14614
  2. a) Have you updated (without uninstall) from a previous version of CIS:
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS:
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):
    No, it is default.
  5. Defense+, Sandbox, Firewall & AV security levels:
  6. OS version, service pack, number of bits, UAC setting, & account type:
    Windows 7 x64 (Service Pack 1)
  7. Other security and utility software currently installed:
    Just Comodo System Utilities and CCleaner.
  8. Other security software previously installed at any time since Windows was last installed:
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]:
    Not a virtual machine.

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

My system is:

Windows 7 Ultimate 32-bit
297 GB HD
1GB memory
Intel (R) Atom ™ CPU 1.67 Ghz N455@1.66Ghz.

I’d just like to add that someone with what appears to be the same bug posted their system specs here. I hope that helps.


Thanks Chiron! Much appreciated


CIS version: 6.0.264710.2708 (Premium edition)
OS version: Windows 7 x86, Home Premium Edition
What you did: Run Quick, Full and Custom Scans
What you actually saw: There was no progress percentage indicator in the window icon (1.jpg). When scan was aborted or finished properly, the icon showed 100% (2.jpg).
What you expected to happen or see: Progress percentage indicator should be shown during scanning as in Rating Scan (3.jpg)

[attachment deleted by admin]

Thank you very much for your issue report.

We would very much appreciate it if you would be kind enough to edit your report to put it in the standard format and add any additional information requested, as this will make it much easier for the developers to diagnose and fix the problem.

The reasons we need all the information in the format, though they may not seem directly relevant to the issue are explained here.

If you are able to do this we will forward this post to the format verified board, where it is more likely to get looked at by developers. You can find assistance using red links in the format and here. If you need further help please ask a mod. If you do not add the information after a day or two we will forward this post to the non-format board. If this happens we will tell you how to rectify this if you wish to.

In the current process we will normally leave it up to you whether you want to make a report in standard format or not. However we may remind you if we think a bug of particular importance.

Many thanks again


Help and GUI-only issue reports do not need to be in the standard format, but we would be very grateful if you would:

a) Summarize the bug in the topic title

b) Include the following information if it’s a GUI bug:
CIS version:
OS version:
What you did:
What you actually saw:
What you expected to happen or see:
A screenshot illustrating to GUI problem

I think I followed the steps you have recommended… ???

Not sure it’s just about the GUI, but it could be I guess, so I’ll forward. (And I should have explained, sorry).

Thank you very much for your report on this GUI or Help text issue, which will now move to the GUI bugs board.

If you have not already done so we would be grateful if you could edit your first post to put the report in the GUI/Help text bugs format, as this makes it easier for developers.

Many thanks in anticipation for your help


This bug still exists in version 6.0.264710.2708. This is for an ASUS K52F computer.

Please feel free to contact me via PM if you have any questions or require additional information.


This issue appears to me to be the same as one already on file. Accordingly, I will merge them, if that’s OK. You can locate the merged report by following the link in the email notification.

If you don’t agree please PM any active mod with your reasons and, if appropriate, they will unmerge the issue.

Many thanks


I saw this post and I have previously tried to have the same issue addressed during a GeekBuddy session.

I have not yet posted a report with any other issues (although I do have one or two).

My question is at what point do you respond to these extremely specific documented request reports so that users such as myself will know what the final outcome is of the these reported issues.

Thank you.

Sadly, Comodo has quite a few bugs to address. Thus, ones such as this may be put off for a while. Hopefully not too long though. :wink:

It would be helpful if you could provide your system details as those may help the devs to narrow down what is causing this behavior.


Rather than having to effectively become an employee to ensure that I follow all of the stringent rules of reporting that you have established, would it not have made more sense for the online tech that responds to the GeekBuddy connection to capture the very same information that you are requesting during the time of the online connection?

Typically, the technician has a direct rdp connection into the computer and should be much more versed in collecting the data, particularly since they are responding to the “call” right at that time. Perhaps you should make this SOP for technicians to ask permission of the paid user to authorize the collection of the report data during the geek buddy call, after which the collected report can then be turned over to the development department, and probably along with the transcript of the GeekBuddy chat session, as well as any notes made by the technician of what the technician did in an attempt to resolve the issue.

Now that I think of it, now that I am aware of the data collection specifications that you have established, during future GeekBuddy sessions, I will make it a point of reminding the technician to collect the data, submit the report, if applicable, to the dev dept., and ask for a confirmation copy to be sent to me for followup. There should then be a case number that the user can track so that the user knows when or if the problem is ever resolved.

We are all trying like mad to get Comodo to give priority to automated reporting. Involving Geekbuddy is an interesting idea.

Meanwhile in order to give the best chance of resolving an issue a report in standard format is your best strategy. It’s much easier than it seems - just cut and paste the format, and put your answers after the colons. The entire second section can be re-used if you have another issue to report.

Very sorry about that.

Best wishes


This is still not fixed with version 6.1.275152.2801.

This is still not fixed with version 6.1.276867.2813.

Tracker updated, thanks

This is not fixed with CIS version 6.2.282872.2847.