full scan completed in 20 sec [M1001]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    Every time
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1:I installed CIS, and after restarting the computer CIS updated and started a full scan of the computer.
    2:The Full scan completed in only 20 seconds “Please see the photos in the attachments”?
    3:Every subsequent scan completes just as fast.
  • If not obvious, what U expected to happen:
    The Full Scan should take far longer. It is likely not really scanning anything.
  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    No idea. However, a Quick Scan takes only 5 seconds. Thus, this is likely a problem with the scanning engine in general.
    A Full Dump of CisTray, made immediately following the end of the Full Scan, can be downloaded from this link.

When running a Full Scan malware sitting on the computer is detected.

[ol]- Exact CIS version & configuration:
CIS 7.0.317799.4142

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    Default configuration
  • Have U made any other changes to the default config? (egs here.):
  • Have U updated (without uninstall) from CIS 5 or CIS6?:
    [li]if so, have U tried a a clean reinstall - if not please do?:
    I have done a clean install, including running the removal tools in Safe Mode after normal install.
    [/li]- Have U imported a config from a previous version of CIS:
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    win7,sp1,32bit in real system
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=none b=none

[attachment deleted by admin]

How long does a Quick Scan take?

Also, is this the first Full Scan you ever ran? If not, how long did the first Full Scan take to complete?


Just to backup sd ahmad’s report, I’ve also had real short Full Scan times on my system. Most times I’ve have completed a Full Scan in under 5 minutes.

5 minutes sounds possible. The reason I say this is that the newer version of CIS keeps track of which files are known to be trusted, and does not scan them again. This is done to improve scanner performance, and can lead to drastically shorter scan times. However, 20s seems much too short a time, even with this technology.

Thus, more information is needed in order to diagnose what may be going on with sd ahmad’s system.

OK, that’s good to know. I thought 5 minutes was very fast. In past versions, it took 20 minutes or better.

How long does a Quick Scan take?
Sometimes minutes at other times 5 seconds


Also, is this the first Full Scan you ever ran? If not, how long did the first Full Scan take to complete?

The same result at all times

In that case this is certainly not normal. Please try reinstalling CIS by following the advice I give in this post. (Even if you already tried this approach please try it once more). Let me know if the problem continues after reinstalling in this way.


I did this already

Thank you for clarifying that. In that case this is very strange.

I have edited the first post slightly. Please create and attach a diagnostics report to your first post (created just after the Full Scan completed).
Also, please create and attach a KillSwitch process list, run directly after the scan has completed.
In addition, please see if you can create a Full Dump through KillSwitch for the cavscan process, run directly after the full scan has finished. You can then upload this to a file sharing site and post the download link in your first post.

Let me know if you run into any trouble creating these.


PM reminder sent.

I will now move this to the Incomplete Issue Reports board.

Topics in this board are not looked at by the devs. The reason is that putting bug reports in the required format, with the required files, ensures that the devs have enough information to understand and identify the bug.

To get your report forwarded to the devs please attach the files I requested. Then let me know.

If you have any questions please do not hesitate to ask.

Thank you.


Unfortunately, the long delay

This report

[attachment deleted by admin]

Thank you. I have edited the first post. Please look it over and let me know if everything looks correct.

Also, were you able to create the Full Dump through KillSwitch of the cavscan process, run directly after the full scan has finished? If not then what happened when you tried to create it?


When do the scan does not show this process

Okay, I wasn’t sure whether it would or not. In that case please make a Full Dump of one of the other Comodo processes, and let me know which one you used. Note that some processes will not allow this dump to be made while others will.


Is this the way a successful

[attachment deleted by admin]

I’m not sure if that would work or not. I had meant to first open KillSwitch. Then, right-click on one of the processes shown through KillSwitch to create the Full Dump.



Thank you for that. I have now added it to the first post.

Please look over the first post carefully and let me know if everything looks correct. If it does I will forward this to the devs.


Has been viewed by me everything true